On Tue, Aug 07, 2018 at 01:05:30PM -0500, C?g wrote:
Robert Nestor wrote:

I?ve run into this a few times using pkgin. Not sure if it?s a problem
with pkgin or with the packages and their dependencies. What seems to
work for me is to remove the newer version of the package that it?s
complaining about, then retrying the installation. In you case, remove
boost-headers-1.67.0nb4, then try the install of libreoffice again.

It has nothing to do with pkgin. OP, run `make deinstall clean` in
devel/boost-headers, and rebuild LibreOffice.

Thanks for offering ideas but building libreoffice still fails, now it's 
complaining about boost-jam-1.65 and the installed boost-jam-1.67.  I tried 
'make deinstall clean' for boost-jam as well, it still fails.

Even if version 1.67 of boost-headers and boost-jam are explicitly uninstalled 
something is convinced they're installed and that's stopping make from just 
building and installing version 1.65 and getting on with building libreoffice.

There must be something in libreoffice's install scripts that's calling 
explicitly for version 1.65 of boost-jam and boost-headers, any idea where I 
should look?

Or how do I really (really) force pkgin and/or pkgsrc to accept that version 
1.67 of them isn't already installed?  I've tried the -f switch but either it's 
broken or I need to flip a switch on something else that I'm unaware of.

I'm at a loss, but willing to try other ideas, thanks to all who are trying to 

Well well well, three naughty, nasty children gone.
Three good, sweet little children left.
(Willy Wonka)

Reply via email to