On 2/14/2018 11:02 AM, David Miller wrote:
Dave I understand your point for generic code and I was not all asking
to rename anything in generic code.
From: Sowmini Varadhan <sowmini.varad...@oracle.com>
Date: Wed, 14 Feb 2018 14:01:10 -0500
On (02/14/18 10:50), Santosh Shilimkar wrote:
generic comment and please update it where it is applicable
in terms of variable names, notifiers etc.
RDS support true zero copy already with RDMA transport so some of
this code can easily get confused.
So I suggest something like below.
I'd like to hear some additional opinions from the list on this:
the existing socket API for TCP etc. already uses ZEROCOPY, and other
than extending variable names (and putting me at risk of violating the
"fit within 80 chars per line" requirement, leading to not-so-pretty
line wraps), I'm not seeing much value in this.
I agree, this name change requires seems pointless. Just keep the names
the way they are, thank you.
My point was new code getting added to RDS to support this zero copy
message option. Within RDS, core code is common and all the
infrastructure with it and it will be hard to follow the code if
that distinction is not maintained.
Ofcourse you have a last say on this list so if you want to
over rule the comment, I will step back :-)