On 2017-01-17 at 16:36:53 +0100, Vadim Kochan <vadi...@gmail.com> wrote:
> On Tue, Jan 17, 2017 at 5:30 PM, Vadim Kochan <vadi...@gmail.com> wrote:
> > Hi Tobias,
> > Just some thoughts from me regarding this commit, if the below
> > can make a sense.
> > In case if list_head (now cds_list_head) will be used by other modules
> > and lets imagine that we will get rid of liburcu dependency (for example
> > if we can make flowtop single threaded) then we will need to have copy-paste
> > cds_* API from urcu or have a wrappers for it, so may be it is better
> > to have generic name w/o cds_ prefix ?
> > Regards,
> > Vadim Kochan
> Sorry for the noise.
> Well now I think that cds_ will be used for RCU like list usage, and
> if to use simple list_head then we will need to have
> local list.h to do not make dpendencies to liburcu.
Exactly. And if you read the reference from the commit, the reason for
the name choice is clearly stated. IMO it's not really nice to hide data
structures and APIs behind #defines just because we don't like the name
or whatever. This will also unnecessarily confuse readers of the code.
You received this message because you are subscribed to the Google Groups
To unsubscribe from this group and stop receiving emails from it, send an email
For more options, visit https://groups.google.com/d/optout.