Simon Josefsson <[email protected]> writes:

> I don't like it a lot either...  I believe the uint8_t version should be
> called salsa20_core.

Agreed.

> The tricky name is the uint32_t variant.
> Ideas:

On this list, I think I'd prefer one of

>   salsa_core_word
>   salsa_core_uint32

Another alternative is to consider the function internal, at least for
the time being, and name it _salsa20_core. One motivation to keep it
internal is that it's suboptimal to have a function processing only a
single block, we may need to generalize it if we want implement other
things, e.g., a proper cryptographic hash function, using this
primitive.

Regards,
/Niels

-- 
Niels Möller. PGP-encrypted email is preferred. Keyid C0B98E26.
Internet email is subject to wholesale government surveillance.
_______________________________________________
nettle-bugs mailing list
[email protected]
http://lists.lysator.liu.se/mailman/listinfo/nettle-bugs

Reply via email to