[ 
https://issues.apache.org/jira/browse/JCLOUDS-1166?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15493070#comment-15493070
 ] 

Ignasi Barrera commented on JCLOUDS-1166:
-----------------------------------------

Yes, just patching the manifest as we've done with the jsch agentproxy

> Remove uses of the 'com.google.gson.internal' package
> -----------------------------------------------------
>
>                 Key: JCLOUDS-1166
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1166
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-chef, jclouds-core
>    Affects Versions: 1.9.2
>            Reporter: Ignasi Barrera
>              Labels: gson
>
> Starting from Gson 2.6, the {{com.google.gson.internal}} packages are no 
> longer exported in the OSGi bundles. This makes it impossible to use jclouds 
> in an OSGi environment if upgrading to such versions of Gson.
> There is no change to add the exports back for that package (see [this 
> discussion|https://github.com/google/gson/pull/916]), so we should stop using 
> those classes.
> See also: http://markmail.org/message/olgebygfgdy3hwtm



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to