GitHub user FrancescoCastaldi added a comment to the discussion: Is fastmcp 4.x supported? MCP server crash-loops after automatic upgrade from 3.4.7
To answer your questions regarding FastMCP compatibility: 1. **Is `fastmcp` 4.x supported in Superset 6.1.0?** No. FastMCP 4.0 is not compatible with Superset 6.1.0. In FastMCP 4.0, the package underwent a major architectural refactor that removed the `fastmcp.tools.tool` module. In Superset 6.1.0, `superset/mcp_service/middleware.py` specifically executes: ```python from fastmcp.tools.tool import Tool, ToolResult ``` When running on FastMCP 4.0, this import raises an `ImportError`. The Superset startup CLI catches this import failure and outputs the generic error: `Error: MCP service dependencies not installed: No module named 'fastmcp.tools.tool'`. 2. **Superset's Declared Dependency Range:** In Superset 6.1.0's `pyproject.toml`, the fastmcp extra is defined as: ```toml fastmcp = ["fastmcp>=3.1.0,<4.0"] ``` Because of the `<4.0` upper bound, upgrading to FastMCP 4 breaks the dependency specification. 3. **Immediate Recovery:** Pin FastMCP to the 3.x release line in your Dockerfile or deployment requirements: ```bash pip install "fastmcp>=3.4.0,<4.0.0" # or specifically: pip install "fastmcp==3.4.7" ``` Avoid running unconstrained `pip install -U fastmcp`. Updating the prerequisite documentation to explicitly cite `pip install "apache-superset[fastmcp]==6.1.0"` or `pip install "fastmcp<4.0"` is a valid documentation improvement. GitHub link: https://github.com/apache/superset/discussions/43822#discussioncomment-19164457 ---- This is an automatically sent email for [email protected]. To unsubscribe, please send an email to: [email protected] --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
