On Fri, 23 Dec 2011 22:45:46 -0500, Austin Clements <amdra...@mit.edu> wrote:
> +    /* True if decryption of this part was attempted. */
> +    notmuch_bool_t decrypt_attempted;
> +    /* True if decryption of this part's child succeeded.  In this
> +     * case, the decrypted part is substituted for the second child of
> +     * this part (which would usually be the encrypted data). */
> +    notmuch_bool_t decrypt_success;
> +
> +    /* True if signature verification on this part was attempted. */
> +    notmuch_bool_t sig_attempted;

I think these new variables make sense, and reflect the correct
semantics, as you already mentioned.

I do, however, think the later variable should be called
"verify_attempted" (or "verification_", or "ver_"?), instead of
"sig_attempted", since verification is the complementary action on a
signed part, just as decryption is for an encrypted one.
"sig_attempted" somehow implies to me that one is trying to make a
signature, not verify an existing one.

jamie.

Attachment: pgpvWlKtMIZ7H.pgp
Description: PGP signature

_______________________________________________
notmuch mailing list
notmuch@notmuchmail.org
http://notmuchmail.org/mailman/listinfo/notmuch

Reply via email to