Hi Shaili,


Thanks for reply.  However, as you can see from my original post, I have
tried that command.  It does not produce the results as expected.  


Indeed, if you read my updated post, you will see that it only seems to
not work when I'm using Click mobilenodes.  Under this condition it
seems to be ignored.


Any other thoughts would be much appreciated!


Best Regards,




From: Shaili Desai [mailto:[EMAIL PROTECTED] 
Sent: 26 February 2007 05:55
To: David Bath
Subject: Re: [ns] new wireless trace format


You need the command $ns_ use-newtrace and that will get you new format.


Hope this helps!



On 2/24/07, David Bath <[EMAIL PROTECTED]> wrote: 

Hi list,

Try as I might, I can't get my wireless traces to spit out in new
format.  I'm using nsclick (compiled with ns2 version 2.3) and it seems
to otherwise be performing fine.

However, when I try the well-documented:

set ns_ [new Simulator]

set tracefd [open "<filename>" w]
$ns_ use-newtrace
$ns_ trace-all $tracefd 

The output resolutely comes out in old format.

I've also tried setting:

Simulator set WirelessNewTrace_ 1  (as seems to be in the ns-lib.tcl)


Simulator set newTraceFormat_ 1 (as seems to be indicated in 

But no joy.

Any suggestions would be very welcome.

Best Regards,

Dave Bath
University of Bristol, UK 

Shaili Desai
Master's Candidate
Telecommunications and Management
University of Maryland,College Park,USA 

Reply via email to