I have a document that includes some grids (drawn with \grid) as well as
alphanumeric information (letters and numbers) which contents (the info,
not the grids) I modify every year and then print it out.  I've been
using it without any problem for a few (maybe 4 or 5) years but, this
time, only the grid showed up on the printout, but none of the letters
or numbers would, using the same printer I used every time before.  I
always copy the PDF file into a USB stick that I bring to the
(departamental) printer, plug it in the printer and directly print from it.

I tried printing the same file (from the same USB drive) into a
different printer, this time connected to a computer, and sending the
file from it, which worked just fine.  My guess is that the first
printer in missing the font the document uses, whereas the second
printer received the font from the computer (Devuan Linux), which has
the appropriate font.  Could that be correct?

In all previous ocasions I used the version of ConTeXt included in
Texlive on Devuan, but a few months ago I decided to install ConTeXt
using the official distribution instead.  Could that explain the change
in behaviour I'm seeing?  Could it be that the previous versions I used
somehow embeded the fonts into the PDF file but the current one doesn't?
And, if that's really the case, how could I force the font to be
included into the PDF file?  I remember I read something like that a
very long time ago (probably about LaTeX, not ConTeXt), but I haven't
found how to do it now in a few searches on the documentation.

Thak you for any help or advice.

If your question is of interest to others as well, please add an entry to the 

maillist : ntg-context@ntg.nl / https://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : https://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki     : https://contextgarden.net

Reply via email to