I’ve just updated to the most recent standalone 

ConTeXt  ver: 2020.01.30 14:13 MKIV beta  fmt: 2020.4.22 (LuaTeX 1.11.1)

and I’m running now into troubles with system font indexing:

mtxrun --script fonts --reload

locates fonts in macOS directories appropriately (*.afm fonts placed in 
.../tex/texmf-fonts are not found, but at the moment I don’t care too much), 
however it resolves only to a single font variant for *.ttc instead of all 

mtxrun --script fonts --list --all --pattern=helvetica

helvetica                         helvetica                    
helveticalightoblique             /System/Library/Fonts/Helvetica.ttc           
helveticalightoblique             helvetica                    
helveticalightoblique             /System/Library/Fonts/Helvetica.ttc           
helveticaneuedeskinterfaceheavy   helveticaneuedeskinterface   
/System/Library/Fonts/HelveticaNeueDeskInterface.ttc   10
helveticaneuethinitalic           helveticaneue                
helveticaneuethinitalic           /System/Library/Fonts/HelveticaNeue.ttc       

As a consequence, when I run

\definefontfamily[mainface][ss][Helvetica Neue]
\setupbodyfont[mainface, 12pt, sans]

I get the light oblique variant instead of the regular one. I have tried to fix 
this via a 

\definefontfamily[mainface][ss][Helvetica Neue][tf=style:normal]

but apparently I understand too little about this setup altogether …

Thanks already for any suggestions!

If your question is of interest to others as well, please add an entry to the 

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki     : http://contextgarden.net

Reply via email to