i have tested maxretry + retrydelay with ups in usb 2.0 port with same result - driver cant start automaticaly, after two manual starts is nut running, so no difference if i specify maxretry 10 retrydelay 20 or 30 or 60 and same results -
driver wont start automaticaly

so i moved with this ups today to test it on 3 another VMware servers and that coincidence works well, i have installed new fresh centos VM, downloaded nut, installed, tried ups on DELL T130 USB 2.0 - nut driver fails to autostart, after 2-3 manual starts it runs, also tried maxretry+ retrydelay also with no difference, ups plugged in USB 3.0, VM usb root hub also 3.0 too and it works!

HP PROLIANT ML110 gen6?or5? + usb addon card 1.1 in PCI slot so i tried 1.1 first - and ups fails with allmost same results, also tried to plug ups into onboard usb 2.0 and leave usb 2.0 root hub in VM - FAILS! so removed VM usb2.0 and added VM usb3.0 hub and ups works great! also i entered into HP bios and switched USB form 2.0 to 1.1 starndard, booted and tested results in VM (onboard forced to 1.1usb and VM usb 3.0hub) runs automaticaly but sometimes ups disconnects, also i switched VM usb to 2.0 and fails again!

unknown DELL rackmount with i5-7500 8g ram - usb 2.0 with VM usb 2.0 fails, usb 2.0 with VM usb 3.0 fails/disconnects, usb 3.0 with VM usb 2.0 fails, usb 3.0 with VM usb 3.0 runs OK

so it looks like some problem with VM ESXi 2.0 HUB but also with slower speed native USB hubs and/or combinations, hope this helps anyone trying to run big BackUPS on ESXi - also note i have BackUPS 1500 BLACK - newer and there are no problems with this newer black model - this one works well same as SmartUPS 1000, SmartUPS1500, SmartUPS750

dunno if NUT developers can solve this issue somehow, but after week of problems this looks like workaround.

-----Původní zpráva----- From: Charles Lepple
Sent: Wednesday, March 28, 2018 3:21 AM
To: p1_p1...@seznam.cz
Cc: nut-upsuser Mailing List
Subject: Re: [Nut-upsuser] problem with nut APC BackUPS RS 1500 (white)

On Mar 27, 2018, at 5:47 PM, <p1_p1...@seznam.cz> wrote:

if somebody has same problem with APC BackUPS (SmartUPS works correctly in same USB) USE FASTEST USB that U have on board, (if you have USB 2.0 and USB 3.0 onboard use one 3.0 port for UPS), sounds like nonsense, but it works, just OMG and halelujah for linux usb drivers.

According to this, your UPS is using the slowest possible USB 1.1 signaling rate, so success after changing from a 2.0 to a 3.0 port might just be coincidence:

T:  Bus=02 Lev=02 Prnt=03 Port=00 Cnt=01 Dev#=  4 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=051d ProdID=0002 Rev=01.06
S:  Manufacturer=American Power Conversion
S:  Product=Back-UPS RS 1500 FW:8.g9 .I USB FW:g9

Also, if you are having intermittent trouble with drivers, you can use the maxrestart and retrydelay options: http://networkupstools.org/docs/man/ups.conf.html

We have had some reports of issues with VMware and USB. This can affect systems with APC UPSes, because the driver needs to be able to pull the model number to apply model-specific fixes. Versions after NUT 2.7.2 have a partial fix for this, but in your case, you should be able to automatically retry with the aforementioned options.=

Nut-upsuser mailing list

Reply via email to