On Thu, Jul 22, 2021 at 3:54 AM Joao Martins <[email protected]> wrote: [..] > > The folio work really touches the page > > cache for now, and this seems mostly to touch the devmap paths. > > > /me nods -- it really is about devmap infra for usage in device-dax for > persistent memory. > > Perhaps I should do s/pagemaps/devmap/ throughout the series to avoid > confusion.
I also like "devmap" as a more accurate name. It matches the PFN_DEV and PFN_MAP flags that decorate DAX capable pfn_t instances. It also happens to match a recommendation I gave to Ira for his support for supervisor protection keys with devmap pfns.
