> These modules set the acpi_device_id::driver_data to 0 but > the field is not actually used within the module, we can > just drop it from the table. > > While we are at it - used a named initializer for the > acpi_device_id::id field to increase readability and > drop explicitly setting the list terminator fields. > > Signed-off-by: Pawel Zalewski (The Capable Hub) > <[email protected]>
Sashiko has reviewed this patch and found no issues. It looks great! -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=6
