On 08/08/17 12:42 AM, Gary Mills wrote:
When I'm publishing some oi-userland components on a SPARC machine, I
get an error message like this:

     ERROR lint.error Checker exception from userland.manifest1001 on
     pkg:/x11/library/libglew@1.13.0,5.11-2016.0.1.0: Illegal FMRI
     'pkg:/SUNWcs@0.5.11-0.152': No build version provided in Version
     constructor: (0.5.11-0.152, None)

followed by several warnings like this:

     WARNING pkglint.action005.1 obsolete dependency check skipped: unable
     to find dependency pkg:/SUNWcs@0.5.11-0.152 for
     pkg:/x11/library/libglew@1.13.0,5.11-2016.0.1.0

What does this all mean?  What should I do to correct the error?



Hi. The warning is harmless, but error is strange. It seems to come from this check: https://github.com/OpenIndiana/oi-userland/blob/d864e28b3dafa531d3f5ae1f9acb33fb754201ec/tools/python/pkglint/userland.py#L450

I'd tried to add some debugging output to find out what's going on.

--
Best regards,
Alexander Pyhalov,
system administrator of Southern Federal University IT department

_______________________________________________
oi-dev mailing list
oi-dev@openindiana.org
https://openindiana.org/mailman/listinfo/oi-dev

Reply via email to