https://bugs.kde.org/show_bug.cgi?id=383155

--- Comment #12 from stardiviner <numbch...@gmail.com> ---
My Okular version is: `okular 1.1.3`.
I searched `epub-tools` in Arch Linux with command `yaourt -Ss epub-tools`,
found it is not installed.
I tried to install it. but failed.
I tried two ways to install `epub-tools`:
Install with Haskell cabal:
```
cabal update ; cabal install epub-tools
```
But get error:
```
Downloading the latest package list from hackage.haskell.org
cabal update  12.36s user 2.14s system 10% cpu 2:23.04 total
Resolving dependencies...
Downloading regex-posix-0.95.2...
Downloading regex-tdfa-1.2.2...
Configuring regex-posix-0.95.2...
Configuring regex-tdfa-1.2.2...
Building regex-posix-0.95.2...
Building regex-tdfa-1.2.2...
Installed regex-posix-0.95.2
Downloading regex-compat-0.95.1...
Configuring regex-compat-0.95.1...
Building regex-compat-0.95.1...
Installed regex-compat-0.95.1
Installed regex-tdfa-1.2.2
Downloading regex-compat-tdfa-0.95.1.4...
Configuring regex-compat-tdfa-0.95.1.4...
Building regex-compat-tdfa-0.95.1.4...
Installed regex-compat-tdfa-0.95.1.4
Downloading epub-metadata-4.5...
Configuring epub-metadata-4.5...
Building epub-metadata-4.5...
Failed to install epub-metadata-4.5
Build log ( /home/stardiviner/.cabal/logs/epub-metadata-4.5.log ):
cabal: Entering directory '/tmp/cabal-tmp-26603/epub-metadata-4.5'
Configuring epub-metadata-4.5...
Building epub-metadata-4.5...
Preprocessing library epub-metadata-4.5...
[ 1 of 24] Compiling Codec.Epub.Util  ( src/Codec/Epub/Util.hs,
dist/build/Codec/Epub/Util.o )
[ 2 of 24] Compiling Codec.Epub.Parse.Util ( src/Codec/Epub/Parse/Util.hs,
dist/build/Codec/Epub/Parse/Util.o )
[ 3 of 24] Compiling Codec.Epub.IO    ( src/Codec/Epub/IO.hs,
dist/build/Codec/Epub/IO.o )
[ 4 of 24] Compiling Codec.Epub.Format.Util (
src/Codec/Epub/Format/Util.hs, dist/build/Codec/Epub/Format/Util.o )
[ 5 of 24] Compiling Codec.Epub.Data.Package (
src/Codec/Epub/Data/Package.hs, dist/build/Codec/Epub/Data/Package.o )
[ 6 of 24] Compiling Codec.Epub.Format.Package (
src/Codec/Epub/Format/Package.hs, dist/build/Codec/Epub/Format/Package.o )
[ 7 of 24] Compiling Codec.Epub.Parse.Package (
src/Codec/Epub/Parse/Package.hs, dist/build/Codec/Epub/Parse/Package.o )
[ 8 of 24] Compiling Codec.Epub.Data.Metadata (
src/Codec/Epub/Data/Metadata.hs, dist/build/Codec/Epub/Data/Metadata.o )
[ 9 of 24] Compiling Codec.Epub.Format.Metadata (
src/Codec/Epub/Format/Metadata.hs, dist/build/Codec/Epub/Format/Metadata.o )
[10 of 24] Compiling Codec.Epub.Parse.Metadata (
src/Codec/Epub/Parse/Metadata.hs, dist/build/Codec/Epub/Parse/Metadata.o )
[11 of 24] Compiling Codec.Epub.Parse.Refinements (
src/Codec/Epub/Parse/Refinements.hs,
dist/build/Codec/Epub/Parse/Refinements.o )
[12 of 24] Compiling Codec.Epub.Data.Common (
src/Codec/Epub/Data/Common.hs, dist/build/Codec/Epub/Data/Common.o )
[13 of 24] Compiling Codec.Epub.Data.Guide ( src/Codec/Epub/Data/Guide.hs,
dist/build/Codec/Epub/Data/Guide.o )
[14 of 24] Compiling Codec.Epub.Format.Guide (
src/Codec/Epub/Format/Guide.hs, dist/build/Codec/Epub/Format/Guide.o )
[15 of 24] Compiling Codec.Epub.Parse.Guide (
src/Codec/Epub/Parse/Guide.hs, dist/build/Codec/Epub/Parse/Guide.o )
[16 of 24] Compiling Codec.Epub.Data.Manifest (
src/Codec/Epub/Data/Manifest.hs, dist/build/Codec/Epub/Data/Manifest.o )
[17 of 24] Compiling Codec.Epub.Format.Manifest (
src/Codec/Epub/Format/Manifest.hs, dist/build/Codec/Epub/Format/Manifest.o )
[18 of 24] Compiling Codec.Epub.Parse.Manifest (
src/Codec/Epub/Parse/Manifest.hs, dist/build/Codec/Epub/Parse/Manifest.o )
[19 of 24] Compiling Codec.Epub.Data.Spine ( src/Codec/Epub/Data/Spine.hs,
dist/build/Codec/Epub/Data/Spine.o )
[20 of 24] Compiling Codec.Epub.Format.Spine (
src/Codec/Epub/Format/Spine.hs, dist/build/Codec/Epub/Format/Spine.o )
[21 of 24] Compiling Codec.Epub.Format ( src/Codec/Epub/Format.hs,
dist/build/Codec/Epub/Format.o )
[22 of 24] Compiling Codec.Epub.Parse.Spine (
src/Codec/Epub/Parse/Spine.hs, dist/build/Codec/Epub/Parse/Spine.o )
[23 of 24] Compiling Codec.Epub.Parse ( src/Codec/Epub/Parse.hs,
dist/build/Codec/Epub/Parse.o )
[24 of 24] Compiling Codec.Epub       ( src/Codec/Epub.hs,
dist/build/Codec/Epub.o )
Preprocessing executable 'epub-metadata-example' for epub-metadata-4.5...
[1 of 1] Compiling Main             ( app/epub-metadata-example.hs,
dist/build/epub-metadata-example/epub-metadata-example-tmp/Main.o )
Linking dist/build/epub-metadata-example/epub-metadata-example ...
/usr/sbin/ld: cannot find -lHSzip-archive-0.3.1.1-CTnIdx1PD2R28s6Hv1Ft3y
/usr/sbin/ld: cannot find -lHSzlib-0.6.1.2-GcLmGV5PElZD6CJvjR9umm
/usr/sbin/ld: cannot find -lHSpretty-1.1.3.3
/usr/sbin/ld: cannot find -lHSold-time-1.1.0.3-EZzkBJ4NQxX4hHavrKxgaT
/usr/sbin/ld: cannot find -lHSold-locale-1.0.0.7-KGBP1BSKxH5GCm0LnZP04j
/usr/sbin/ld: cannot find -lHSdigest-0.0.1.2-ExF2dwgnnwj5rxxaZYWSiQ
/usr/sbin/ld: cannot find -lHSutf8-string-1.0.1.1-1DpjxLeTvGg7ttZZojxJR5
/usr/sbin/ld: cannot find -lHSregex-base-0.93.2-AYjYAsBidAc8f5XNm9b2Aa
/usr/sbin/ld: cannot find -lHShxt-9.3.1.16-YawaVI4czs2GYj8uhLpnV
/usr/sbin/ld: cannot find -lHSnetwork-uri-2.6.1.0-GzRvaV3udR3JtWfa3CLYOw
/usr/sbin/ld: cannot find -lHShxt-unicode-9.0.2.4-91NbsYmAW3YHFFSyOss7u4
/usr/sbin/ld: cannot find
-lHShxt-regex-xmlschema-9.2.0.3-EJ79sDbAiO4CJ0CjtkP17K
/usr/sbin/ld: cannot find -lHSparsec-3.1.11-1CA7c0vSU7tJHGhveOjoXR
/usr/sbin/ld: cannot find -lHStext-1.2.2.2-3ENqlljngKa6xj1Go2fVWq
/usr/sbin/ld: cannot find -lHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6
/usr/sbin/ld: cannot find -lHStransformers-0.5.2.0
/usr/sbin/ld: cannot find
-lHShxt-charproperties-9.2.0.1-48OogeCJMUc1lcYcm9OQtr
/usr/sbin/ld: cannot find -lHSbinary-0.8.3.0
/usr/sbin/ld: cannot find -lHSdirectory-1.3.0.0
/usr/sbin/ld: cannot find -lHSunix-2.7.2.1
/usr/sbin/ld: cannot find -lHStime-1.6.0.1
/usr/sbin/ld: cannot find -lHSfilepath-1.4.1.1
/usr/sbin/ld: cannot find -lHScontainers-0.5.7.1
/usr/sbin/ld: cannot find -lHSbytestring-0.10.8.1
/usr/sbin/ld: cannot find -lHSdeepseq-1.4.2.0
/usr/sbin/ld: cannot find -lHSarray-0.5.1.1
/usr/sbin/ld: cannot find -lHSbase-4.9.1.0
/usr/sbin/ld: cannot find -lHSinteger-gmp-1.0.0.1
/usr/sbin/ld: cannot find -lHSghc-prim-0.5.0.0
/usr/sbin/ld: cannot find -lHSrts
collect2: error: ld returned 1 exit status
`gcc' failed in phase `Linker'. (Exit code: 1)
cabal: Leaving directory '/tmp/cabal-tmp-26603/epub-metadata-4.5'
cabal: Error: some packages failed to install:
epub-metadata-4.5 failed during the building phase. The exception was:
ExitFailure 1
epub-tools-2.9 depends on epub-metadata-4.5 which failed to install.
```

Then I try to install it through Arch AUR:
```
yaourt -S epub-tools
```
But failed too. Because Amazon S3 mirror network is not available to me
(China).
```
==> Continue building epub-tools ? [Y/n]
==> ------------------------------------
==> y

==> Building and installing package
==> Making package: epub-tools 2.9-2 (Mon Aug  7 14:46:21 CST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found epub-tools-2.9.tar.gz
==> Validating source files with sha256sums...
    epub-tools-2.9.tar.gz ... Passed
==> Extracting sources...
  -> Extracting epub-tools-2.9.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...
Selected mirror https://s3.amazonaws.com/hackage.fpcomplete.com/
Downloading timestamp
Updating package index Hackage (mirrored at
https://s3.amazonaws.com/hackage.fpcomplete.com/) ...SomeRemoteError
(HttpExceptionRequest Request {
  host                 = "s3.amazonaws.com"
  port                 = 443
  secure               = True
  requestHeaders       =
[("Accept-Encoding",""),("Cache-Control","no-transform")]
  path                 = "/hackage.fpcomplete.com/timestamp.json"
  queryString          = ""
  method               = "GET"
  proxy                = Nothing
  rawBody              = False
  redirectCount        = 10
  responseTimeout      = ResponseTimeoutDefault
  requestVersion       = HTTP/1.1
}
 ConnectionTimeout)
==> ERROR: A failure occurred in package().
    Aborting...
==> ERROR: Makepkg was unable to build epub-tools.
==> Restart building epub-tools ? [y/N]
==> -----------------------------------
==>
```

[stardiviner]           <Hack this world!>      GPG key ID: 47C32433
IRC(freeenode): stardiviner                     Twitter:  @numbchild
Key fingerprint = 9BAA 92BC CDDD B9EF 3B36  CB99 B8C4 B8E5 47C3 2433
Blog: http://stardiviner.github.io/

On Sun, Aug 6, 2017 at 10:53 PM, Yuri Chornoivan <bugzilla_nore...@kde.org>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=383155
>
> --- Comment #11 from Yuri Chornoivan <yurc...@ukr.net> ---
> The last file attached (kk.epub) can be successfully opened and read using
> Okular 1.0.3 + epub-tools 0.2.2 on Mageia 6. So this might be a
> distribution
> problem.
>
> --
> You are receiving this mail because:
> You reported the bug.
>

-- 
You are receiving this mail because:
You are the assignee for the bug.

Reply via email to