Hi all,

I've been trying to deploy the ONAP entire platform in my local environment
following the official documentation without the desired results:

   - First, I tried the amsterdam release installation:
      - kubectl 1.7.7
      - rancher 1.6.10
      - helm 2.3.0
      - docker 1.12
      - onap deployment using oom:
         - install/deployment/cd.sh
         - oom/kubernetes/oneclick/createAll.sh

Some of the pods are returning errors like:

Error syncing pod
Back-off restarting failed container
(combined from similar events): Error: failed to start container
"filebeat-onap-aai-model-loader": Error response from daemon:
header field value* \"oci runtime error: container_linux.go:247: starting
container process caused \\\"process_linux.go:359: container init caused
\\\\\\\"rootfs_linux.go:53: mounting
to rootfs
caused \\\\\\\\\\\\\\\"not a directory\\\\\\\\\\\\\\\"\\\\\\\"\\\"\\n\""}

   - Then, I tried with beijing/master:
      - kubectl 1.8.6
      - rancher 1.6.14
      - helm 2.6.1
      - docker 17.03
      - onap deployment using helm install local/onap

Some of the pods are not starting because they cannot pull the image. It
seems that large images produces a timeout. I found something related with
increasing a kubelet config parameter, but the followed k8s installation
guide does not produce any kubelet installation.

It seems that the code is not stable enough, but i saw that many people are
working with the platform so is possible to deploy it.

How did you deploy the platform? Is there any hidden step that I'm missing?


BR, Santi
*Santiago Rodríguez García* | Senior Analyst
T/ + 34 986 410 091 (ext) 227
[image: Optare Solutions] <http://optaresolutions.com/>
onap-discuss mailing list

Reply via email to