Hi,

I'm observing some strange behavior from a range of Linux
distributions running open-iscsi: they're not following a redirect in
discovery mode.

When I run:
iscsiadm --mode discovery --type sendtargets --portal portal_ip

the initiator connects to the portal, which then sends a "redirect"
packet with a new TargetAddress value.
Under RHEL 4.6 this is accepted and the initiator retries discovery on
the new target. However on Ubuntu, RHEL 5.x and SuSE 10 the redirect
is silently ignored.

The only difference between these systems is the implementation of
iSCSI they run - SFNet (linux-iscsi?) on RHEL 4 and open-iscsi on the
others. I've made packet captures to see whether the initial target
sends the same response to either system, and it does.

The working platform is RHEL 4 update 6, running kernel 2.6.9-67.ELsmp
and iscsi-initiator-utils-4.0.3.0-6

The non-working platforms are RHEL 5 update 1, Ubuntu 7.10 and 8.04
and SuSE 10, all running the most recent version of open-iscsi from
repositories. I have also tried compiling from latest source release,
but the issue remains.

I have looked around the web, but haven't found a similar issue which
suggests that this may be a simple config issue, which I have just not
found yet. However, if anyone has any thoughts on this, please share!

regards,
Lukasz Szmit
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to