Our client platform is a HP DL-585 (AMD) machine, with RedHat
Enterprise 5.1 x86_64, iscsi-initiator-utils-6.2.0.865-0.8.el5, dm-
multipath, redhat cluster suite and virtualization packages.

We replaced the original, basic script for xend bridged networking
with a custom one - actually, a wrapper of the original one. The
wrapper recalls the script three times with different parameter, thus
creating three bridges with different settings.
Using that wrapper over the basic script, we noticed a significant
delay while the wrapper script is being activated at boot time
("enabling xen networking workaround...").

While the wrapper script waits to complete, errors/warnings from iscsd
came up:

  iscsid: Nop-out timedout after 15 seconds on connection 1:0 state
(3).    Dropping session

We have tried to solve that by modifying timeout values in
iscsid.conf:

node.conn[0].timeo.noop_out_interval = 20
node.conn[0].timeo.noop_out_timeout = 30

but iscsid gives always the same error (Nop-out timedout after 15
seconds). We feel like iscsid doesn't read the configuration file. We
are asking if this value is possibly hard coded in iscsid executable,
or if there is another way to alter this timeout value (or even is
possibly a problem of RedHat patching to the original package).

Thank you so much, best regards
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to