Yeah, that worked; thanks guys. I did see the ib_iser errors on startup but it 
looks like it just didn't load due to the symbol problems discussed in the 
readme.

aptitude install linux-headers-`uname -r`
wget http://www.open-iscsi.org/bits/open-iscsi-2.0-869.2.tar.gz
tar -xvzf open-iscsi-2.0-869.2.tar.gz
cd open-iscsi-2.0-869.2
make
dpkg-divert --divert /lib/modules/2.6.18-6-686/kernel/drivers/scsi/libiscsi.ko 
/lib/modules/2.6.18-6-686/kernel/drivers/scsi/libiscsi.ko.debian
dpkg-divert --divert /lib/modules/2.6.18-6-686/kernel/drivers/scsi/iscsi_tcp.ko 
/lib/modules/2.6.18-6-686/kernel/drivers/scsi/iscsi_tcp.ko.debian
dpkg-divert --divert 
/lib/modules/2.6.18-6-686/kernel/drivers/scsi/scsi_transport_iscsi.ko 
/lib/modules/2.6.18-6-686/kernel/drivers/scsi/scsi_transport_iscsi.ko.debian
cp kernel/iscsi_tcp.ko /lib/modules/2.6.18-6-686/kernel/drivers/scsi/
cp kernel/libiscsi.ko /lib/modules/2.6.18-6-686/kernel/drivers/scsi/
cp kernel/scsi_transport_iscsi.ko /lib/modules/2.6.18-6-686/kernel/drivers/scsi/

-----Original Message-----
From: Andrew Moise [mailto:[EMAIL PROTECTED]
Sent: Friday, May 16, 2008 10:16 PM
To: open-iscsi@googlegroups.com; Bryan Mclellan
Subject: Re: System hanging with MD3000i with Debian Etch

On Fri, May 16, 2008 at 5:30 PM, Bryan Mclellan <[EMAIL PROTECTED]> wrote:
> I have a debian etch (vmware guest) box running 2.6.18-6-686. With both 
> open-iscsi 2.0.730-1etch1 and 2.0.869.2-2 (from sid) the system hangs when 
> trying to log in to the MD3000i. Not having done this before I'm fooling 
> around with directions from [1] and running:

  The 2.6.18 kernel that ships with etch has some problems with iscsi;
what worked for me was to divert the Debian iscsi modules and install
ones that I compiled from the open-iscsi tarball.  There should be
instructions on how to do that in the open-iscsi README.
  Alternatively, you can install a 2.6.25 or newer kernel; I preferred
to stay with the Debian kernel to get security updates and whatnot,
but I also tried 2.6.25 and it survived some amount of iscsi stress
testing.
  Cheers.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to