Donald Williams wrote:
> Mike,
> I decided to try the current repository version (as of 3PM, 7/15).  Compiled
> and installed w/o issue.  Rebooted and I couldn't connect to my EQL targets.
> The login process complained "no iSCSI driver".    So I installed 2.0-871
> from the website tar ball.   Rebooted, same problem.  Tried an older kernel,
> 2.6.24-23, came up fine.   Installed (stupidly) the git version on that
> kernel, reboot, couldn't log in either.  Again, trying to downgrade failed.
>  Installed an even older kernel, 2.6.24-22 installed 871 from the tar ball,
> that worked fine.   Removed the modified kernels and re-installed one,
> 2.6.24-24, then installed 871 from tar ball, works fine.
>  I'm running ubuntu 8.04 LTS.  2.6.24-24-generic kernel right from ubuntu.
> Is this anything you've seen?
>  What I see in the log that's different is, non-working configs had these
> errors.
> Jul 15 15:17:56 ietd-tape kernel: [   73.760376] Loading iSCSI transport
> class v2.0-871.
> Jul 15 15:17:56 ietd-tape kernel: [   73.789017] iscsi_tcp: Unknown symbol
> iscsi_tcp_segment_done

I think you or the Makefile just needs to run depmod.

There is a new iscsi module, so there is now


The above error log messages indicated that you are using a newer 
iscsi_tcp module but the libiscsi_tcp is not getting loaded.

I think we have been getting lucky and since the older modules were the 
same as the distro they got loaded right. Now with the new module we 
should probably add a depmod in the Makefile somewhere. Do you by any 
chance know how to hack Makefiles?

You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to