On 02/24/2011 02:35 AM, Aastha Mehta wrote:
I get the same error that is mentioned in one of the posts on this
thread. On the target I get:
$/etc/init.d/iscsitarget restart
$dmesg
iscsi_trgt: fileio_attach(283) -5
iscsi_trgt: Registered io type fileio
iscsi_trgt: Registered io type blockio
iscsi_trgt: Registered io type nullio
iscsi_trgt: open_path(119) Can't open /media/myDrive/newhdfs/storage/
lun3_2.img -5

I think when you restart the target, because you hit this problem the target does not startup correctly.

now, when i run open-iscsi on the initiator, this is what i see:
$/etc/init.d/open-iscsi restart

So when we restart the initiator logs out but is not able to log back in.

$cat /var/log/messages
aasthainitiator-desktop kernel: connection12:0: detected conn
error(1020)
aasthainitiator-desktop kernel: iscsi: registered transport (iser)

$fdisk -l
$cat /var/log/messages
aasthainitiator-desktop kernel: session recovery timed out after 120
secs

so here we have waited 120 secs to try and login, but could not so we start failing IO.

aasthainitiator-desktop kernel: sd 82:0:0:0: [sdd] Unhandled error
code
aasthainitiator-desktop kernel: sd 82:0:0:0: Result:
hostbyte=DID_TRANSPORT_FAILFAST driverbyte=DRIVER_OK
aasthainitiator-desktop kernel: sd 82:0:0:0: CDB: Read(10): 28 00 00
00 00 00 00 00 08 00


--
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com.
To unsubscribe from this group, send email to 
open-iscsi+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/open-iscsi?hl=en.

Reply via email to