It's useful in a number of places to get an identifier for a particular
Configuration. For example, as we discussed a few months ago, it would
be useful if the logging subsystem automatically wrote the persistence
unit's ID along with log messages if no such ID was specified in the log

Any objections to such an addition? In a JPA environment, this would
correspond to the persistence unit's unitName attribute.

Any suggestions for a better name than openjpa.Id for the property? This
would result in an OpenJPAConfiguration.getId() method call that
returned a String.


Patrick Linskey
BEA Systems, Inc. 

Notice:  This email message, together with any attachments, may contain
information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
entities,  that may be confidential,  proprietary,  copyrighted  and/or
legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient,
and have received this message in error, please immediately return this
by email and then delete it.

Reply via email to