Good point. I'll clean that up on my next commit. Kevin
On 2/1/07, Craig L Russell <[EMAIL PROTECTED]> wrote:
Hi Kevin, Good changes. Here's where I would have put a comment: On Feb 1, 2007, at 2:53 PM, [EMAIL PROTECTED] wrote: > Broker broker; > for (Iterator itr = _brokers.iterator(); itr.hasNext > ();) { > broker = (Broker) itr.next(); > - if (!broker.isClosed()) /* Check for null here because _brokers is a weak reference collection */ > + if ((broker != null) && (!broker.isClosed())) > broker.close(); Craig Russell Architect, Sun Java Enterprise System http://java.sun.com/products/jdo 408 276-5638 mailto:[EMAIL PROTECTED] P.S. A good JDO? O, Gasp!