Worked - I have voice! Thanks Pau.

But GPRS is not ok yet. I'm running osmo-bts-lc15 and osmo-pcu in the
LC15, and the core network in my development pc.

osmo-sgsn gives me:

20180223001319967 DMM <0002> gprs_sgsn.c:726
MM(724056406933460/ccb930f7) Subscriber data update
20180223001319967 DMM <0002> sgsn_auth.c:219
MM(724056406933460/ccb930f7) Updating authorization (unknown ->
20180223001319967 DMM <0002> sgsn_auth.c:236
MM(724056406933460/ccb930f7) Missing auth tuples, authorization not possible
20180223001319967 DMM <0002> sgsn_auth.c:248
MM(724056406933460/ccb930f7) Got authorization update: state unknown ->
20180223001319967 DMM <0002> gprs_gmm.c:1140
MM(724056406933460/ccb930f7) Not authorized, rejecting ATTACH REQUEST
with cause 'IMSI unknown in HLR' (2)
20180223001319967 DMM <0002> gprs_gmm.c:489 MM(724056406933460/ccb930f7)

But I added the IMSIs in HLR with
subscriber imsi 724056406933460 create
subscriber imsi 724056406933460 update msisdn 12345678

I run (nightly builds):
osmo-stp -c osmo-stp.cfg
osmo-bsc -c osmo-bsc-lc15.cfg
osmo-msc -c osmo-msc.cfg
osmo-hlr -l hlr.db -c osmo-hlr.cfg
osmo-mgw -c osmo-mgw-msc.cfg
osmo-mgw -c osmo-mgw-bsc.cfg
osmo-sgsn -c osmo-sgsn.cfg
sudo osmo-ggsn -c osmo-ggsn.cfg

Attached goes my configuration files.

Rafael Diniz

On 02/21/2018 12:36 PM, Pau Espin Pedrol wrote:
> On 21/02/18 14:09, Rafael Diniz wrote:
>> Hi Pau,
>> Can I use loopback addresses or should I use local network addresses?
> Unless I'm forgetting some detail, it shuld be fine to run everything
> with loopback addresses.
>> Btw, osmo-bsc_mgcp still need to be called together with current git
>> osmo-msc and osmo-mgw, right?
> As far as I know latest osmo-msc already requires osmo-mgw.

Attachment: osmocom_configs.tar.gz
Description: application/gzip

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to