Well I see a valid point in keeping them separated.
PACKAGECONFIG is just a static list of things, while the other setting
is based on DISTRO_FEATURES. If we merge them, we kind force any
override from local or distro.conf to copy the DISTRO_FEATURES block
into their code or remove the DISTRO_FEATURES check - none of the
options is a good one IMHO.
With that in mind I personally would like to keep them separate and just
fix the append.
Regards
Konrad
On 03.06.20 10:44, Richard Purdie wrote:
On Tue, 2020-06-02 at 22:44 +0200, Konrad Weihmann wrote:
As ??= assignment will be overwritten by += in any case,
one can't define a default of PACKAGECONFIG in this recipe.
Using _append instead mitigates chances of accidental overwriting
the default
Signed-off-by: Konrad Weihmann <[email protected]>
---
meta/recipes-devtools/ruby/ruby_2.7.1.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meta/recipes-devtools/ruby/ruby_2.7.1.bb b/meta/recipes-
devtools/ruby/ruby_2.7.1.bb
index 3dd9fb0a62..3d7d095fbf 100644
--- a/meta/recipes-devtools/ruby/ruby_2.7.1.bb
+++ b/meta/recipes-devtools/ruby/ruby_2.7.1.bb
@@ -12,7 +12,7 @@ SRC_URI[md5sum] =
"debb9c325bf65021214451660f46e909"
SRC_URI[sha256sum] =
"d418483bdd0000576c1370571121a6eb24582116db0b7bb2005e90e250eae418"
PACKAGECONFIG ??= ""
-PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
+PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES',
'ipv6', d)}"
Shouldn't this just be:
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
?
Cheers,
Richard
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#139165):
https://lists.openembedded.org/g/openembedded-core/message/139165
Mute This Topic: https://lists.openembedded.org/mt/74636783/21656
Group Owner: [email protected]
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub
[[email protected]]
-=-=-=-=-=-=-=-=-=-=-=-