On Mon, Dec 16, 2024 at 8:50 AM Antonin Godard <[email protected]> wrote:
> Hi Bruce, > > On Mon Dec 16, 2024 at 2:29 PM CET, Bruce Ashfield via > lists.openembedded.org wrote: > > On Mon, Dec 16, 2024 at 8:21 AM Bruce Ashfield <[email protected] > > > > wrote: > > > >> > >> > >> On Mon, Dec 16, 2024 at 6:35 AM Antonin Godard < > [email protected]> > >> wrote: > >> > >>> Following commit a39a1f7cf78ad1ca07438bce634a47e970f25047 > >>> ("kernel-yocto: allow early exit to configuration audit"), we can > >>> disable auditing of the kernel configuration by setting KMETA_AUDIT > >>> empty. > >>> > >>> Since the default value of this variables is "yes", use > >>> oe.types.boolean() so that it will also be disabled when setting it to > >>> "no", and avoid potential confusion. > >>> > >> > >> That isn't the intent of the variable. It is being used as a flag here, > >> but it can also be used to encode other information. > >> > >> Quite literally, if it is set to anything, the audit should happen. Only > >> when it is unset should it not. > >> > > > > I hit send too soon. It's Monday. > > > > What I wanted to add was this question: Is that still the behaviour with > > the boolean call ? If so, no concerns from me. > > It seems that this is the only place where the KMETA_AUDIT variable is > used so I > figured its role was to enable/disable the audit and only that. Maybe the > "audit_flag" name is a bit misleading then? > Maybe, but I'd rather not change the name if nothing is broken. I normally just put a comment above the variable to indicate that sort of behaviour (i.e. # if this variable is set to anything non-zero an audit will be performed), but I for some reason didn't do that here! There are some audit modes for in-tree configs that I'm working on that will use that variable to change modes (different from the allnoconfig/alldefconfig flags that are already used). Bruce > > The behavior of the boolean call is to return False if KMETA_AUDIT == > "no", so > it _is_ different from "if set to anything, the audit happens". > > > Antonin > > -- > Antonin Godard, Bootlin > Embedded Linux and Kernel engineering > https://bootlin.com > -- - Thou shalt not follow the NULL pointer, for chaos and madness await thee at its end - "Use the force Harry" - Gandalf, Star Trek II
-=-=-=-=-=-=-=-=-=-=-=- Links: You receive all messages sent to this group. View/Reply Online (#208765): https://lists.openembedded.org/g/openembedded-core/message/208765 Mute This Topic: https://lists.openembedded.org/mt/110142731/21656 Group Owner: [email protected] Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [[email protected]] -=-=-=-=-=-=-=-=-=-=-=-
