Hi Bruce,

On Mon Dec 16, 2024 at 2:29 PM CET, Bruce Ashfield via lists.openembedded.org 
wrote:
> On Mon, Dec 16, 2024 at 8:21 AM Bruce Ashfield <[email protected]>
> wrote:
>
>>
>>
>> On Mon, Dec 16, 2024 at 6:35 AM Antonin Godard <[email protected]>
>> wrote:
>>
>>> Following commit a39a1f7cf78ad1ca07438bce634a47e970f25047
>>> ("kernel-yocto: allow early exit to configuration audit"), we can
>>> disable auditing of the kernel configuration by setting KMETA_AUDIT
>>> empty.
>>>
>>> Since the default value of this variables is "yes", use
>>> oe.types.boolean() so that it will also be disabled when setting it to
>>> "no", and avoid potential confusion.
>>>
>>
>> That isn't the intent of the variable. It is being used as a flag here,
>> but it can also be used to encode other information.
>>
>> Quite literally, if it is set to anything, the audit should happen. Only
>> when it is unset should it not.
>>
>
> I hit send too soon. It's Monday.
>
> What I wanted to add was this question: Is that still the behaviour with
> the boolean call ? If so, no concerns from me.

It seems that this is the only place where the KMETA_AUDIT variable is used so I
figured its role was to enable/disable the audit and only that. Maybe the
"audit_flag" name is a bit misleading then?

The behavior of the boolean call is to return False if KMETA_AUDIT == "no", so
it _is_ different from "if set to anything, the audit happens".


Antonin

-- 
Antonin Godard, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#208764): 
https://lists.openembedded.org/g/openembedded-core/message/208764
Mute This Topic: https://lists.openembedded.org/mt/110142731/21656
Group Owner: [email protected]
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub 
[[email protected]]
-=-=-=-=-=-=-=-=-=-=-=-

  • Re: [OE-core] [PATCH] kernel-yoc... Antonin Godard via lists.openembedded.org

Reply via email to