On Fri, 2013-05-10 at 11:32 +0100, Richard Purdie wrote: > On Fri, 2013-05-10 at 12:20 +0200, Martin Jansa wrote: > > On Fri, May 10, 2013 at 01:15:10PM +0300, Bogdan Marinescu wrote: > > > Removed the patches to flex, because they are now applied to the > > > latest version. > > > > Can you check if 2.5.37 still reports flex.real when you call > > flex --version? > > > > If yes, please integrate > > http://lists.linuxtogo.org/pipermail/openembedded-core/2013-May/039425.html > > I'll send v2 with added ${S} in a minute > > I'm really not convinced we should be hacking flex to fix this. Can't > whatever parsing is being done to extract the version be a little more > relaxed about the name?
Or we could patch create_wrapper() to put the original binary in a different directory (but keep the same leafname) rather than renaming it to foo.real. That would also address Martin's other concern with flex++ not knowing its own name. p. _______________________________________________ Openembedded-core mailing list [email protected] http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core
