On Wed, 2015-07-22 at 10:29 +0800, He Zhe wrote: > On 07/21/2015 10:53 PM, Christopher Larson wrote: > > > > On Tue, Jul 21, 2015 at 12:23 AM, <[email protected] > > <mailto:[email protected]>>wrote: > > > > From: He Zhe <[email protected] <mailto:[email protected]>> > > > > To support building packaging and installing multi types of kernel > > images, such as zImage uImage, at one time define KERNEL_IMAGETYPE > > as a list. > > Modify wherever reference KERNEL_IMAGETYPE accordingly. > > > > Fixes [YOCTO #6945]. > > > > Signed-off-by: He Zhe <[email protected] > > <mailto:[email protected]>> > > > > > > Question, why not add KERNEL_IMAGETYPES, and make KERNEL_IMAGETYPE equal to > > your new KERNEL_IMAGETYPE_0? > > Adding a new KERNEL_IMAGETYPES will also work. But it should be better > not to change the name of KERNEL_IMAGETYPE, so that those who have > used it don't have to change their code. > > Thank you for reviewing.
I have to agree with Chris here, keeping KERNEL_IMAGETYPE as used today and equivalent to KERNEL_IMAGETYPE_0 and adding KERNEL_IMAGETYPES does seem like a cleaner way to implement this. Cheers, Richard -- _______________________________________________ Openembedded-core mailing list [email protected] http://lists.openembedded.org/mailman/listinfo/openembedded-core
