Hi all,

about one hour ago, I have update BE (saw FF update). Then I wanted to remove network/ssh-askpass/zenity (looks like it is not usable, but did not analyzed it properly) and got this error:



$ pfexec pkg uninstall -v pkg://openindiana.org/network/ssh-askpass/zenity
Creating Plan (Solver setup): /
pkg uninstall: Package service/network/ssh must be uninstalled before the requested operation can be performed.
  Reject:  pkg://openindiana.org/service/network/ssh@7.4.0.1-2017.0.0.3
Reason: No version matching 'require' dependency network/ssh can be installed
    ----------------------------------------
    Reject:  pkg://openindiana.org/network/ssh@7.4.0.1-2017.0.0.3
Reason: No version matching 'conditional' dependency network/ssh-askpass can be installed
      ----------------------------------------
      Reject:  pkg://openindiana.org/network/ssh-askpass@1.0-2017.0.0.0
Reason: No version matching 'conditional' dependency network/ssh-askpass/zenity can be installed
        ----------------------------------------
Reject: pkg://openindiana.org/network/ssh-askpass/zenity@1.0-2017.0.0.0
        Reason:  This version rejected by user request
        ----------------------------------------
      ----------------------------------------
    ----------------------------------------
Package archiver/gnu-tar must be uninstalled before the requested operation can be performed.
  Reject:  pkg://openindiana.org/archiver/gnu-tar@1.29-2017.0.0.0
Reason: No version matching 'require' dependency network/ssh@7.2.0.2-2017.0.0.4 can be installed Package network/ssh must be uninstalled before the requested operation can be performed.
  Reject:  pkg://openindiana.org/network/ssh@7.4.0.1-2017.0.0.3
  Reason:  [already rejected; see above]
Package network/ssh-askpass must be uninstalled before the requested operation can be performed.
  Reject:  pkg://openindiana.org/network/ssh-askpass@1.0-2017.0.0.0
  Reason:  [already rejected; see above]
Package metapackages/build-essential must be uninstalled before the requested operation can be performed. Reject: pkg://openindiana.org/metapackages/build-essential@1.0-2017.0.0.9 Reason: No version matching 'require' dependency archiver/gnu-tar can be installed

This package is not crucial for functionality, so it is maybe/probably related to REQUIRED_PACKAGES recent changes.

Regards.
--
Predrag Zečević
Technical Support Analyst
2e Systems GmbH

tel: +49 - 6196 - 95058 - 15
mob: +49 - 174 - 3109288
fax: +49 - 6196 - 95058 - 94
e-mail: predrag.zece...@2e-systems.com

headquarter: 2e Systems GmbH, Koenigsteiner Str. 87, 65812 Bad Soden am Taunus, Germany
registration: Amtsgericht Koenigstein (Germany), HRB 7303
managing director: Phil Douglas

http://www.2e-systems.com/ - Making your business fly!

_______________________________________________
openindiana-discuss mailing list
openindiana-discuss@openindiana.org
https://openindiana.org/mailman/listinfo/openindiana-discuss

Reply via email to