i build
with the VS 2010 express (as suggested at the wiki).

I think that Express only supports 32-bit builds, but I may be wrong. Anyway, glad to hear you are able to build!

If you want to know when the accessibility sources are back in the repo, you can look for the commit messages or watch JIRA issue https://javafx-jira.kenai.com/browse/RT-37536 (although I'm sure Steve or Felipe will send a message).

If you don't want to wait, you could apply Felipe's patch from that JIRA issue to your local build and try it yourself before then.

-- Kevin

Jann Schneider wrote:
ok i just rebuild using the 32 bit jdk and this works!
$ gradle clean sdk


I think i've just installed the 32 bit C++ compilers only. Maybe i
missed a setting in the installer of visual studio .. btw. i build
with the VS 2010 express (as suggested at the wiki).

So i'll wait until the accessibility portion is back in the repo and
try with that included then. Thanks for your help so fahr!
@Steve: could you please send a short message to the list if the
accessibility sources are in the repo again?


2014-06-20 23:50 GMT+02:00, Jann Schneider <jann.schnei...@googlemail.com>:
Yes looks like i have an issue with looking up cl.exe.
This was the output when running with --stacktrace:

* Exception is:
org.gradle.api.tasks.TaskExecutionException: Execution failed for task
Caused by: org.gradle.api.GradleException: Could not call
NativeCompileTask.compile() on task ':fxpackager:buildJavaPackager'
Caused by: java.util.concurrent.ExecutionException:
org.gradle.process.internal.ExecException: A problem occurred starting
process 'command 'C:/Program Files (x86)/Microsoft Visual Studio
Caused by: java.io.IOException: Cannot run program "C:/Program Files
(x86)/Microsoft Visual Studio 10.0/VC/BIN/amd64/cl.exe" (in directory
"D:\jann\sandbox\java\openjfx\modules\fxpackager"): CreateProcess
error=2, Das System kann die angegebene Datei nicht finden
Caused by: java.io.IOException: CreateProcess error=2, Das System kann
die angegebene Datei nicht finden (file not found)

Actually cl.exe is located at: C:\Program Files (x86)\Microsoft Visual
Studio 10.0\VC\bin - but it looks for ...bin/amd64/cl.exe

I've also tried to run the build from the cygwin terminal and as well
from the visual studio command prompt where i could call cl.exe
directly .. Always the same result.

Is there a parameter to specify where theVS compiler and stuff is
located? btw. i checked that the %VS100COMNTools% variable is set

What else could i check? Thanks in advance :)


2014-06-20 23:30 GMT+02:00, Kevin Rushforth <kevin.rushfo...@oracle.com>:
* What went wrong:
Execution failed for task ':fxpackager:buildJavaPackager'.

Could not call NativeCompileTask.compile() on task
When I've seen this in the past it's been related to the compiler
install. Do you have VS 2010 SP1 or something else?

-- Kevin

Jann Schneider wrote:

Well on windows it's always a bit more difficult i guess :-)
After setting up my build environment as described on the wiki i first
$ gradle tasks
This works as expected! When running
$ gradle sdk
or just gradle without any target i get the following error:

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':fxpackager:buildJavaPackager'.

Could not call NativeCompileTask.compile() on task

Is this a "known issue" and do you know what's going wrong here?
Should i post more "info" or "debug" output, too?


2014-06-20 21:58 GMT+02:00, Stephen F Northover

Being non-Unix, Windows is always a pain.


On 2014-06-20, 3:42 PM, Kevin Rushforth wrote:

I hope you have similar success with the Windows build.

-- Kevin

Jann Schneider wrote:

Hi all,

The build instructions for linux where very good! I was able to build
the project without any problems.

Regards Jann

2014-06-20 19:27 GMT+02:00, Kevin Rushforth

To be clear, you will still use the 8u-dev repo at the existing URL:


It's just that after Monday the repo will "become" the place where
work is done.

Regarding the build, it is a bit painful to set up for Windows, but
too bad as long as you don't need to build WebKit. We would be
interested in hearing whether the instructions on the Wiki are
sufficient for you to get the build working.

-- Kevin

Stephen F Northover wrote:

Ok, let us know how you get on with building FX.

NOTE: The accessibility code is not there in 8u20 so you will just
ensuring that you can build on Windows (there is nothing there to
test).  The accessibility code will be going back into 8u40 on
or Tuesday so you'll need to get that release at that time and
it instead when it becomes available.  It's good to debug the build
process though because it can be painful building from source.


On 2014-06-20, 12:43 PM, Jann Schneider wrote:

Hi all,

@Steven: thx for the links. I'll try to build the openjfx project
the windows 7 notebook and test the sample apps with NVDA then.
Today i tried the latest ea of jdk1.8.0_20 and sample apps with
14.2. Unfortunately i was not able to read anything except the
I've just installed the jdk, changed my JAVA_HOME and tried to run
e.g. the ensemble.jar
$ java -jar ensemble.jar -Djavafx.accessible.force=true

Well i'll try it again by means of building javafx from source and
post my results back to the list.

Regards Jann!

2014-06-20 14:46 GMT+02:00, Stephen F Northover

Hello Jann!

As soon as the 8u40 repos open, the Accessibility code will be
put back
along with the recent fixes for JAWS.  Since OpenJFX (and the
JDK) does
not have nightly builds, unless you want to wait for an EA build
or 9, you will need to get OpenJFX and build it.  This is really
best way to work with the team anyway because you can get fixes
as they
are made.  EA builds take a while to come out and there is no
for running on the latest code base.

Unfortunately due to Microsoft, building OpenJFX is a bit harder
Windows.  However, it is doable and the build instructions should
complete.  If they are not (and if you hit any problems), please
back to this list.

Here are the build instructions:


Many committers use an IDE (you don't have to) and OpenJFX is
the three major IDE vendors:


Looking forward to working with you,

On 2014-06-19, 7:10 PM, Felipe Heidrich wrote:

Hi Jann,

Unfortunately Linux support is not in the plan for 8u40.

Windows 7 is supported and we have recently fixed JAWS support
https://javafx-jira.kenai.com/browse/RT-37530 and
Unfortunately due to the 8u20 to 8u40 transition the code has
released yet, but soon.

The majority of our testing was done using Narrator. That said,
I also
tested NVDA lastest version on Windows 8 and I didn’t see any
On the Mac we tested with VoiceOver.


On Jun 19, 2014, at 2:24 PM, Jann Schneider
<jann.schnei...@googlemail.com> wrote:

Hello all,

As a blind java developer i'm interessted in testing the
accessibility of
JavaFX and maybe help to find some issues.

I've just set up my build environment on my ubuntu 14.04 laptop
checked out the project files as described in the wiki. I could
also set
it up on a windows 7 with Jaws 15 and NVDa (don't know what the
version is) for comparison..

No i am wondering if there are some examples i could try?

Regards Jann

Reply via email to