Hi, Michael.

Could you provide more details about your system and steps to reproduce the problem(at least, a command line)? We will investigate this issue about SetFile failure.


--Victor

On 2/13/18 2:36 PM, Michael Paus wrote:
The bug you mentioned is indeed fixed in JDK 10 but since I upgraded my
Mac to Hight Sierra there seems to be a new one. I always get something
like:

Exec failed with code 2 command [[/usr/bin/SetFile, -c, icnC, /var/folders/0q/r4k4hbd13_s0p0thlz2hs8b80000gn/T/fxbundler10792917345996316721/images/myApp/.VolumeIcon.icns] in unspecified directory

My Mac now uses APFS and I wonder whether SetFile can cope with that.
According to the docs it has long been deprecated and should not be used
anymore anyway. The build as a whole succeeds though. It just cannot
handle the volume icon although it exists and has always worked before.

Michael

Am 13.02.18 um 22:41 schrieb Kevin Rushforth:
Have you tried with JDK 10 yet? The bug you reference is fixed in 10.

-- Kevin


Steve Hannah wrote:
I ran into this bug a couple months ago with javafx packager on High Sierra.
https://bugs.java.com/bugdatabase/view_bug.do?bug_id=8190758

The problem is basically that hdiutil changed its default file system to APFS, which breaks many things. Ultimately I wasn't able to get javafx
packager to work even with the workarounds listed on that bug so just
generated the DMG using a 3rd party script (
https://github.com/andreyvit/create-dmg) to work around it.

Steve

On Tue, Feb 13, 2018 at 12:05 PM, Tom Schindl <tom.schi...@bestsolution.at>
wrote:

Hi,

It looks like the packaging of JavaFX-DMGs is broken on the latest OS-X
System. Has anyone ancountered the same?

Tom






Reply via email to