On Tue, 25 Aug 2020 14:07:08 GMT, Jeanette Winzenburg <faste...@openjdk.org> 
wrote:

>> Ambarish Rapte has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   change approach from removing to excluding
>
> modules/javafx.controls/src/test/java/test/javafx/scene/control/ComboBoxTest.java
>  line 1344:
> 
>> 1343:
>> 1344:     @Test public void test_EditorKeyInputsWhenPopupIsShowing() {
>> 1345:         final ComboBox<String> cb = new 
>> ComboBox<>(FXCollections.observableArrayList("a", "b", "c"));
> 
> minor nit: naming is inconsistent to the other added test below 
> (testExcludeKeyMappingsForComboBoxEditor) - either use
> an underscore or not (my personal preference is to not use them at all, 
> following general java naming conventions also
> in tests .. but definitely not overly important :)

Removed _, changed to `testEditorKeyInputsWhenPopupIsShowing`

> modules/javafx.controls/src/test/java/test/javafx/scene/control/ListViewTest.java
>  line 2055:
> 
>> 2054:                 .observableArrayList("Item1", "Item2"));
>> 2055:         listView.setCellFactory(TextFieldListCell.forListView());
>> 2056:         StageLoader sl = new StageLoader(listView);
> 
> hmm .. why the textFieldListCell? It's just a plain listCell if not in 
> editing state .. or not?

It is effect of copy paste ;), Test behaves as expected even without it, so 
removed.

-------------

PR: https://git.openjdk.java.net/jfx/pull/172

Reply via email to