On Sun, 16 Jan 2022 12:25:13 GMT, Nir Lisker <nlis...@openjdk.org> wrote:
>> John Hendrikx has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Fix grammar mistakes and did some small rephrases > > modules/javafx.base/src/main/java/javafx/beans/value/ObservableValue.java > line 189: > >> 187: * holds {@code null}; can be {@code null} >> 188: * @return an {@code ObservableValue} holding this {@code >> ObservableValue}'s value, >> 189: * or the given value it is {@code null}; never returns {@code >> null} > > `or the given value it is {@code null}` missing "when" or "if"? Fixed this with "if" > modules/javafx.base/src/test/java/test/javafx/beans/value/ObservableValueFluentBindingsTest.java > line 271: > >> 269: @Test >> 270: void shouldReturnPropertyValuesWithOperationApplied() { >> 271: assertEquals((Integer) 65, >> observableValue.getValue()); > > I don't think that the cast is needed as autoboxing will take care of it. > Fine to leave as-is. I rewrote this now anyway to use strings, and I made the fluent binding test a bit easier to follow (I hope). ------------- PR: https://git.openjdk.java.net/jfx/pull/675