On Thu, 13 Aug 2026 17:53:35 GMT, Andy Goryachev <[email protected]> wrote:
> Updated `KeyCodeCombination.getDisplayText()` to return "NumPad *" text for
> all numpad keys:
>
>
> Arguments.of("NumPad 0", KeyCode.NUMPAD0),
> Arguments.of("NumPad 1", KeyCode.NUMPAD1),
> Arguments.of("NumPad 2", KeyCode.NUMPAD2),
> Arguments.of("NumPad 3", KeyCode.NUMPAD3),
> Arguments.of("NumPad 4", KeyCode.NUMPAD4),
> Arguments.of("NumPad 5", KeyCode.NUMPAD5),
> Arguments.of("NumPad 6", KeyCode.NUMPAD6),
> Arguments.of("NumPad 7", KeyCode.NUMPAD7),
> Arguments.of("NumPad 8", KeyCode.NUMPAD8),
> Arguments.of("NumPad 9", KeyCode.NUMPAD9),
> Arguments.of("NumPad *", KeyCode.MULTIPLY),
> Arguments.of("NumPad +", KeyCode.ADD),
> Arguments.of("NumPad -", KeyCode.SUBTRACT),
> Arguments.of("NumPad .", KeyCode.DECIMAL),
> Arguments.of("NumPad /", KeyCode.DIVIDE)
>
>
> Added test for numpad and also modified the test case where we have
> platform-specific differences (Backspace, Delete, ...)
>
> NOTE: noticed the auto-generated text shows weird names - "Back Space"
> instead of "Backspace". We might want to double check and fix these as well.
>
> some names are weird, perhaps these should also be fixed:
>
> KeyCode.BACK_SPACE: Back Space
> KeyCode.QUOTEDBL: Quotedbl
> KeyCode.EJECT_TOGGLE: Eject Toggle
> KeyCode.KP_DOWN: Kp Down
> KeyCode.KP_LEFT: Kp Left
> KeyCode.KP_RIGHT: Kp Right
> KeyCode.KP_UP: Kp Up
>
> Also, there is difference in naming certain keys between macOS keyboards and
> the rest of the world:
>
> esc - Esc
> backspace == delete
> return - Enter
> caps lock - Caps Lock
> shift - Shift
>
> The use of symbols for macOS is questionable in my opinion, maybe the
> keyboard have changed since then:
>
> KeyCode.BACK_SPACE: ⌫
> KeyCode.DELETE: ⌦
> KeyCode.ESCAPE: ⎋
>
> ---------
> - [x] I confirm that I make this contribution in accordance with the [OpenJDK
> Interim AI Policy](https://openjdk.org/legal/ai).
You bring a good point, though `getDisplayText()` might be used by the
application in other scenarios (shortcut preferences come to mind).
"Num": I am not sure about this. Swing does "NumPad-0" or "NumPad .", though
on mac it uses ⌨ = \u2328 symbol which is total nonsense. I think "NumPad" is
still a better choice for consistency reasons.
There is an option of using ⊞ (U+229E, SQUARED PLUS) on mac, but it's debatable.
Do agree with capitalization - lowercase looks more like a stylistic choice (I
have keyboards with both capitalized and all-lowercase labels.
PgUp/PgDn is probably a reasonable abbreviation.
-------------
PR Comment: https://git.openjdk.org/jfx/pull/2257#issuecomment-5296277445