> Updated `KeyCodeCombination.getDisplayText()` to return "NumPad *" text for 
> all numpad keys:
> 
> 
>             Arguments.of("NumPad 0", KeyCode.NUMPAD0),
>             Arguments.of("NumPad 1", KeyCode.NUMPAD1),
>             Arguments.of("NumPad 2", KeyCode.NUMPAD2),
>             Arguments.of("NumPad 3", KeyCode.NUMPAD3),
>             Arguments.of("NumPad 4", KeyCode.NUMPAD4),
>             Arguments.of("NumPad 5", KeyCode.NUMPAD5),
>             Arguments.of("NumPad 6", KeyCode.NUMPAD6),
>             Arguments.of("NumPad 7", KeyCode.NUMPAD7),
>             Arguments.of("NumPad 8", KeyCode.NUMPAD8),
>             Arguments.of("NumPad 9", KeyCode.NUMPAD9),
>             Arguments.of("NumPad *", KeyCode.MULTIPLY),
>             Arguments.of("NumPad +", KeyCode.ADD),
>             Arguments.of("NumPad -", KeyCode.SUBTRACT),
>             Arguments.of("NumPad .", KeyCode.DECIMAL),
>             Arguments.of("NumPad /", KeyCode.DIVIDE)
> 
> 
> Added test for numpad and also modified the test case where we have 
> platform-specific differences (Backspace, Delete, ...)
> 
> NOTE: noticed the auto-generated text shows weird names - "Back Space" 
> instead of "Backspace".  We might want to double check and fix these as well.
> 
> some names are weird, perhaps these should also be fixed:
> 
> KeyCode.BACK_SPACE: Back Space
> KeyCode.QUOTEDBL: Quotedbl
> KeyCode.EJECT_TOGGLE: Eject Toggle
> KeyCode.KP_DOWN: Kp Down
> KeyCode.KP_LEFT: Kp Left
> KeyCode.KP_RIGHT: Kp Right
> KeyCode.KP_UP: Kp Up
> 
> Also, there is difference in naming certain keys between macOS keyboards and 
> the rest of the world:
> 
> esc - Esc
> backspace == delete
> return - Enter
> caps lock - Caps Lock
> shift - Shift
> 
> The use of symbols for macOS is questionable in my opinion, maybe the 
> keyboard have changed since then:
> 
> KeyCode.BACK_SPACE: ⌫
> KeyCode.DELETE: ⌦
> KeyCode.ESCAPE: ⎋
> 
> ---------
> - [x] I confirm that I make this contribution in accordance with the [OpenJDK 
> Interim AI Policy](https://openjdk.org/legal/ai).

Andy Goryachev has updated the pull request incrementally with one additional 
commit since the last revision:

  pgup pgdn esc backspace

-------------

Changes:
  - all: https://git.openjdk.org/jfx/pull/2257/files
  - new: https://git.openjdk.org/jfx/pull/2257/files/1b2f5dae..76dfd885

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jfx&pr=2257&range=01
 - incr: https://webrevs.openjdk.org/?repo=jfx&pr=2257&range=00-01

  Stats: 70 lines in 2 files changed: 39 ins; 11 del; 20 mod
  Patch: https://git.openjdk.org/jfx/pull/2257.diff
  Fetch: git fetch https://git.openjdk.org/jfx.git pull/2257/head:pull/2257

PR: https://git.openjdk.org/jfx/pull/2257

Reply via email to