On Mon, 17 Aug 2026 18:37:10 GMT, Andy Goryachev <[email protected]> wrote:
>> I was referring to the first inline comment that you made above on this
>> line, which is `* <li>Parameters: </li>`:
>>
>>> Parameters: should describe the structure (see BOUNDS_FOR_RANGE for example)
>>
>> There are no parameters.
>>
>>> ListViewSkin L386 returns the int[] with { firstIndex, count } which needs
>>> to be documented.
>>
>> So you are saying that the _return value_ (not parameters) needs to better
>> documented. Quite possibly.
>
> I am using terminology used in the `AccessibleAttribute` class. For example,
> L91 specifies the "Parameters:", whatever that is. Perhaps it should be
> renamed "Structure:" or something like that.
>
> edit: Also, we should probably drop the "Parameters:" `<li>` when it's empty.
Parameters is consistently used in this class to mean _input_ parameters. The
example from L91 (`BOUNDS_FOR_RANGE `) are input parameters. For this new
attribute, as with many (most) others, there are none.
> Perhaps it should be renamed "Structure:" or something like that.
Why? Parameters is used elsewhere (e.g., for method parameters) to mean
effectively the same thing. No need to invent a new term.
> Also, we should probably drop the "Parameters:" `<li>` when it's empty.
Maybe, but that's tangential to this PR.
-------------
PR Review Comment: https://git.openjdk.org/jfx/pull/2217#discussion_r3798392623