On Thu, 27 Aug 2026 11:17:09 GMT, Michael Strauß <[email protected]> wrote:
> This PR is an audit of several snapping-related methods in `Region`, along > with some bug fixes. > > I've added a helper method `snapAligned()`, which does the exact same thing > as `snapSpace()`, but clearly states that the author knows that the value is > already pixel-aligned. In addition, I've renamed several local variables > around a "rawFoo" and "snappedFoo" naming scheme, so as to make it easier to > see what's what. > > This PR should probably be integrated before the other layout container PRs, > because those use the `Region` layout methods. > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai). This pull request has now been integrated. Changeset: 7db4a9dd Author: Michael Strauß <[email protected]> URL: https://git.openjdk.org/jfx/commit/7db4a9dda9880d7c4370de56f5c1ed5fda6c7429 Stats: 788 lines in 3 files changed: 643 ins; 24 del; 121 mod 8391279: Fix pixel-snapping in Region Reviewed-by: jhendrikx, mhanl, angorya ------------- PR: https://git.openjdk.org/jfx/pull/2278
