-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://codereview.secondlife.com/r/365/#review825
-----------------------------------------------------------


Looking good overall. Please fix the minor issues.


indra/newview/llpanelpermissions.cpp
<http://codereview.secondlife.com/r/365/#comment833>

    What is the "KC" label for?



indra/newview/llpanelpermissions.cpp
<http://codereview.secondlife.com/r/365/#comment834>

    Coding standard: rewrite as btn_mark_for_sale.



indra/newview/llpanelpermissions.cpp
<http://codereview.secondlife.com/r/365/#comment835>

    ditto



indra/newview/llpanelpermissions.cpp
<http://codereview.secondlife.com/r/365/#comment837>

    What does the comment mean?



indra/newview/llpanelpermissions.cpp
<http://codereview.secondlife.com/r/365/#comment838>

    Please consider moving the duplicated code to a separate method like
    enableMarkForSale(bool enabled);



indra/newview/llpanelpermissions.cpp
<http://codereview.secondlife.com/r/365/#comment839>

    Follow the CS when naming local variables.


- Vadim


On June 27, 2011, 6:44 p.m., Kadah Coba wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://codereview.secondlife.com/r/365/
> -----------------------------------------------------------
> 
> (Updated June 27, 2011, 6:44 p.m.)
> 
> 
> Review request for Viewer.
> 
> 
> Summary
> -------
> 
> This change makes it so setting an object for sale or modifying the price or 
> sale type requires explicitly applying the changes. Default behavior before 
> this patch is all sale info is committed to sim on change. After this patch 
> the sale info will only get set or modified after hitting a "mark for sale" 
> button. There is no change to removing an object from sale, unchecking "For 
> sale" will be committed to sim without further user interation.
> 
> https://bitbucket.org/Kadah_Coba/vwr-21522
> Main Patch: https://bitbucket.org/Kadah_Coba/vwr-21522/changeset/45df3e1e9f6f
> German translation: 
> https://bitbucket.org/Kadah_Coba/vwr-21522/changeset/01dc58391588
> 
> 
> This addresses bug VWR-21522.
>     http://jira.secondlife.com/browse/VWR-21522
> 
> 
> Diffs
> -----
> 
>   indra/newview/llpanelpermissions.h b245a988d038 
>   indra/newview/llpanelpermissions.cpp b245a988d038 
>   indra/newview/skins/default/xui/en/floater_tools.xml b245a988d038 
> 
> Diff: http://codereview.secondlife.com/r/365/diff
> 
> 
> Testing
> -------
> 
> (I had stuff here but Review Board kept deleting it every time I tried to 
> save.)
> 
> 
> Thanks,
> 
> Kadah
> 
>

_______________________________________________
Policies and (un)subscribe information available here:
http://wiki.secondlife.com/wiki/OpenSource-Dev
Please read the policies before posting to keep unmoderated posting privileges

Reply via email to