On Wed, Apr 4, 2018 at 9:00 AM, Noam Angel <no...@mellanox.com> wrote:
> Hi,
>
> First check you can ping the.
> Then open a browser and login.
> Make sure ipmi enabled.
> Make sure user has permissions for admin or other role with reboot
> capabilities.
> Check again

Hi, yeah. So like I mention in my initial email IPMI is working great
with a password like this:

ipmitool -I lanplus -H 172.31.0.19 -U Administrator -P password power status

It just fails when Ironic sends the similar command with a password
file. It appears that the password file is the issue. Tried it with
and without newlines even and no success.

Dan

>
> Get Outlook for Android
>
> ________________________________
> From: Dan Prince <dpri...@redhat.com>
> Sent: Wednesday, April 4, 2018 3:39:00 PM
> To: List, OpenStack
> Subject: [openstack-dev] [Ironic][Tripleo] ipmitool issues HP machines
>
> Kind of a support question but figured I'd ask here in case there are
> suggestions for workarounds for specific machines.
>
> Setting up a new rack of mixed machines this week and hit this issue
> with HP machines using the ipmi power driver for Ironic. Curious if
> anyone else has seen this before? The same commands work great with my
> Dell boxes!
>
> -----
>
> [root@localhost ~]# cat x.sh
> set -x
> # this is how Ironic sends its IPMI commands it fails
> echo -n password > /tmp/tmprmdOOv
> ipmitool -I lanplus -H 172.31.0.19 -U Adminstrator -f /tmp/tmprmdOOv
> power status
>
> # this works great
> ipmitool -I lanplus -H 172.31.0.19 -U Administrator -P password power status
>
> [root@localhost ~]# bash x.sh
> + echo -n password
> + ipmitool -I lanplus -H 172.31.0.19 -U Adminstrator -f /tmp/tmprmdOOv
> power status
> Error: Unable to establish IPMI v2 / RMCP+ session
> + ipmitool -I lanplus -H 172.31.0.19 -U Administrator -P password power
> status
> Chassis Power is on
>
> Dan
>
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Flists.openstack.org%2Fcgi-bin%2Fmailman%2Flistinfo%2Fopenstack-dev&data=02%7C01%7Cnoama%40mellanox.com%7Cb8324698c48e4fba8de408d59a293ae2%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636584424239254168&sdata=o2D26f1zFNmaM%2BOhQKD0SKaqqISRYdNzVotcR%2Fdqyhc%3D&reserved=0
>
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to