pycodestyle-2.4.0 added new warnings W605 and W606, which needs to be
addressed or future versions of python3 will refuse to run.

https://github.com/PyCQA/pycodestyle/pull/676

(OpenStack CI's flake8 is pre pycodestyle age, flake8 version isn't
managed by g-r, but that's another story. No release of flake8
supports pycodestyle 2.4.0 yet. ;)

nova seems to have ~200 of those warnings, while other projects don't
have much, FWIW.

--
IWAMOTO Toshihiro

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to