On 2018-05-17 16:09:12 +0900 (+0900), IWAMOTO Toshihiro wrote:
[...]
> OpenStack CI's flake8 is pre pycodestyle age,

It's not "OpenStack CI's flake8" version. Nova's master branch is
getting flake8 transitively through its test-requirement on
hacking!=0.13.0,<0.14,>=0.12.0 which is causing it to select
hacking==0.12.0 (the only version between 0.12.0 and 0.14.0 is
0.13.0 which is explicitly skipped). In turn, that version of
hacking declares a requirement on flake8<2.6.0,>=2.5.4 which is
causing it to use flake8==2.5.5. As you noted, that depends on
pep8!=1.6.0,!=1.6.1,!=1.6.2,>=1.5.7 so pep8==1.7.1 gets used.

> flake8 version isn't managed by g-r, but that's another story.
[...]

The reason we don't globally-constrain hacking, flake8 or other
static analyzers is that projects are going to want to comply with
new rules at their own individual paces; it's up to the Nova team to
decide when to move their master branch testing to new versions of
these. Per the example above if they upped their hacking cap to <1.2
they would get hacking==1.1.0 (the latest release) which would
install flake8==2.6.2 and so pycodestyle==2.0.0.
-- 
Jeremy Stanley

Attachment: signature.asc
Description: PGP signature

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to