I am trying to run the Rally scenario boot-runcommand-delete. This scenario has 
the following code
 def boot_runcommand_delete(self, image, flavor,
                               script, interpreter, username,
                               ip_version=4, port=22,
                               use_floatingip=True, **kwargs):
  server = None
        floating_ip = None
            print "fixed network:%s floating network:%s" 
            server = self._boot_server(
                image, flavor, key_name='rally_ssh_key', **kwargs)

            self.check_network(server, fixed_network)

The question I have is the instance is created with a call to boot_server but 
no networks are attached to this server instance. Next step it goes and checks 
if the fixed network is attached to the instance and sure enough it fails
At the step highlighted in bold. Also I cannot see this failure unless I run 
rally with –v –d object. So it actually reports benchmark scenario numbers in a 
table with no errors when I run with
rally task start boot-and-delete.json

And reports results. First what am I missing in this case. Thing is I am using 
neutron not nova-network
Second when most of the steps in the scenario failed like attaching to network, 
ssh and run command why bother reporting the results


OpenStack-dev mailing list

Reply via email to