Anyone know what happened to (or is happening) to:

https://github.com/pypa/pip/issues/988

'Pip needs a real dependency resolver'

Maybe it's time we as a community helped pip get that feature in?

-Josh

On Sep 3, 2014, at 5:37 AM, Sean Dague <s...@dague.net> wrote:

> I'm not sure why people keep showing up with "sort requirements" patches
> like - https://review.openstack.org/#/c/76817/6, however, they do.
> 
> All of these need to be -2ed with predjudice.
> 
> requirements.txt is not a declarative interface. The order is important
> as pip processes it in the order it is. Changing the order has impacts
> on the overall integration which can cause wedges later.
> 
> So please stop.
> 
>       -Sean
> 
> -- 
> Sean Dague
> http://dague.net
> 
> _______________________________________________
> OpenStack-dev mailing list
> OpenStack-dev@lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


_______________________________________________
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to