On 10/02/2014 11:23 AM, Jay S. Bryant wrote:
As I re-read this I think maybe you have answered my question but want to be clear. You feel that 'State' is the only term that should be used. Based on the definitions above, that would make sense. The complication is there are may places in the code where a variable like 'status' is used. Don't think we are going to be able to go back and fix all those, but it would be something that is good to watch for in reviews in the future.
I'm talking about new versions of the public APIs that get proposed, not existing ones. Within the codebase, it would be great to use a single term "state" for this, prefixed with a refining descriptor like "power_", "task_", etc. But that's a lesser concern for me than our next generation REST APIs.
Best, -anotherjay _______________________________________________ OpenStack-dev mailing list OpenStackemail@example.com http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev