On 11/11/14 09:30, Jiri Tomasek wrote:
On 11/10/2014 12:19 PM, Matthias Runge wrote:
On Thu, Oct 30, 2014 at 01:13:48PM +0100, Matthias Runge wrote:
tl;dr: how to progreed in separating horizon and openstack_dashboard
About a year ago now we agreed, it makes sense to separate horizon and
At the past summit, we discussed this again. Currently, our repo
contains two directories: horizon and openstack_dashboard, they both
will need new names.
We discussed a renaming in the past; the former consensus was:
rename horizon to horizon_lib and
rename openstack_dashboard to horizon.
IMHO that doesn't make any sense and will confuse people a lot. I
wouldn't object to rename horizon to horizon_lib, although any other
name, e.g django-horizon should be fine as well.
openstack_dashboard is our official name; people from outside refer to
the Dashboard as Horizon, why not rename to openstack_horizon here?
It is official name, but I disagree that people refer more to Dashboard
than to Horizon. People mostly talk about Horizon and when they say
Horizon they refer to the UI. Dashboard is not much used outside Horizon
community and is a bit confusing (overloaded).
Small example - when you want to add the general overview page - the
actual dashboard, that should be the *dashboard* name how it should be
used. Otherwise we are adding _Dashboard_ view into Project's
_dashboard_ into OpenStack _Dashboard_ project. That's what I really see
My opinion and preference:
* horizon_lib (framework) + horizon (UI)
Thoughts? Opinions? Suggestions?
From what was discussed on contributors meetup, keeping the names
'horizon' for the lib (framework) and 'openstack_dashboard' for
dashboard seemed most convenient. And I happen to aggree with that.
Not sure if it seemed the most convenient, I haven't seen agreement there.
OpenStack-dev mailing list