Thank you very much for the clarification :)

On 02/11/15 12:15, Daniel P. Berrange wrote:
> On Wed, Feb 11, 2015 at 12:03:58PM +0100, Pasquale Porreca wrote:
>> Thank you for all answers.
>> I know that meta data tags are "free" to use with any key/value, still
>> there are some specific values that triggers pieces of code in nova (or
>> maybe even in other components). In particular I am working on one of
>> these key/value, in my case it should enable the
>> <bios rebootTimeout=value/>
>> parameter in libvirt. Anyway even if my code is merged, no one will know
>> about it (except myself and the reviewers) if it is not documented
>> somewhere. A DocImpact flag was added to the commit message, but I still
>> don't know how to proper document it. I may create/update existing wiki
>> pages, but I would have preferred an official documentation: I was not
>> able to find the wiki page proposed by Daniel Berrange, even if I had
>> been searching exactly to something similar :(
>> It is very good that there is a work to objectify image meta, anyway is
>> there any recommendation  how to document it in the meanwhile?
> For people submitting patches to nova the expectation is simply that they
> add DocImpact and have a commit message that describes the usage of the
> new property. The docs team work from this data. There's no current formal
> docs that I'd expect you to be editing/updating.
>> I would also know if there is any naming convention for image meta and
>> flavor extra-spec keys: in my case I used hw_reboot_timeoutand
>> hw:reboot_timeout respectively, but it is more a bios than hardware
>> feature and they are handled in nova/virt/libvirt/ rather than
>> nova/virt/ so maybe the name choice was not so good.
> In terms of image metadata, broadly speaking, we're aiming to standardize
> on 3 name prefixes in Nova
>  'hw' - stuff that affects guest hardware configuration (this includes
>         the BIOS settings, since that's hardware firmware)
>  'os' - stuff that affects the guest operating system setup
>  'img' - stuff Nova uses related to managing images
> So, your choice of 'hw_reboot_timeout' for image and 'hw:reboot_timeout'
> for the flavour  is correct.
> Regards,
> Daniel

Pasquale Porreca

DEK Technologies
Via dei Castelli Romani, 22
00040 Pomezia (Roma)

Mobile +39 3394823805
Skype paskporr

OpenStack Development Mailing List (not for usage questions)

Reply via email to