Hello community,

here is the log from the commit of package hplip for openSUSE:Factory checked 
in at 2016-12-01 10:24:28
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/hplip (Old)
 and      /work/SRC/openSUSE:Factory/.hplip.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "hplip"

Changes:
--------
--- /work/SRC/openSUSE:Factory/hplip/hplip.changes      2016-09-30 
15:20:30.000000000 +0200
+++ /work/SRC/openSUSE:Factory/.hplip.new/hplip.changes 2016-12-01 
10:24:29.000000000 +0100
@@ -1,0 +2,34 @@
+Wed Nov 23 20:19:53 UTC 2016 - martin.wi...@suse.com
+
+- Fixed SLES12 SP2 build problem in
+  %files section for /usr/lib/udev/rules.d
+
+------------------------------------------------------------------.
+Fri Nov 18 11:23:38 UTC 2016 - jweberho...@weberhofer.at
+
+- Version upgrade to 3.16.10:
+  * Added Support for the Following New Printers:
+    - HP officejetPro7740 wide  Format All in one
+    - HP Office jet 6950 All-in-One printer
+    - HP ScanJet Pro 3000 s3 Sheet-feed Scanner
+    - HP ScanJet Enterprise Flow 5000 s4 Sheet-feed Scanner
+    - HP Scanjet Entrprise Flow 7000 s3 sheetfeed Scanner
+    - HP Color LaserJet Pro MFP M277c6
+  * Notes to follow:
+    - For scanjets scan using command "hp-scan --adf --size=size_name"
+    - "hp-scan --help" for all size_name
+
+-------------------------------------------------------------------
+Tue Oct 18 03:56:26 UTC 2016 - jweberho...@weberhofer.at
+
+- Version upgrade to 3.16.9:
+  * Added Support for the Following New Printers:
+    - HP OfficeJet Pro 8732M All-in-One Printer
+    - HP OfficeJet 8702 All-in-One Printer
+    - HP OfficeJet 6960 All-in-One Printer
+    - HP PageWide 377dw Multifunction Printer
+    - HP PageWide 352dw Printer
+    - HP PageWide Managed Color MFP E58650 series
+    - HP PageWide Managed Color E55650 series
+
+-------------------------------------------------------------------

Old:
----
  hplip-3.16.8.tar.gz
  hplip-3.16.8.tar.gz.asc

New:
----
  hplip-3.16.10.tar.gz
  hplip-3.16.10.tar.gz.asc

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ hplip.spec ++++++
--- /var/tmp/diff_new_pack.zcUeLS/_old  2016-12-01 10:24:31.000000000 +0100
+++ /var/tmp/diff_new_pack.zcUeLS/_new  2016-12-01 10:24:31.000000000 +0100
@@ -21,9 +21,19 @@
 %else
 %define is_leap 0
 %endif
-
+# For udev macros
+%if 0%{?suse_version} > 1130
+BuildRequires:  systemd-rpm-macros
+%else
+# For older suse_version (in particular for SLE11) define needed udev macros 
manually:
+%{!?_udevrulesdir: %global _udevrulesdir %{_prefix}/lib/udev/rules.d }
+%endif
+%if 0%{?suse_version} == 1110
+# For SLE11 redefine _libexecdir because on SLE11 _libexecdir is "/usr/lib64":
+%global _libexecdir %{_prefix}/lib
+%endif
 Name:           hplip
-Version:        3.16.8
+Version:        3.16.10
 Release:        0
 Summary:        HP's Printing, Scanning, and Faxing Software
 License:        BSD-3-Clause and GPL-2.0+ and MIT
@@ -60,43 +70,6 @@
 Patch200:       hplip-mdns.patch
 # Patch201 makes MDNS lookups more robust by retrying queries:
 Patch201:       hplip-mdns-retry-query.patch
-# HPLIP's Python module cupsext.so has a build-time dependancy on the CUPS 
version:
-# It needs symbols (like ippFirstAttribute, ippNextAttribute, ippSetOperation 
etc)
-# that are defined only in libcups.so version > 1.5. For backward compatibility
-# cupsext.c has a macro (CUPS_VERSION_1_6) which defines those undefined 
function names
-# if CUPS version is <= 1.5. To check the CUPS version the CUPS_VERSION_MAJOR, 
CUPS_VERSION_MINOR
-# macros from cups/cups.h are used which means it depends on the CUPS version 
during build-time
-# whether or not cupsext will work with CUPS <= 1.5 at run-time.
-# See https://bugs.launchpad.net/hplip/+bug/1423220
-# and https://bugzilla.opensuse.org/show_bug.cgi?id=918387
-# Therefore it BuildRequires the CUPS version as provided in the openSUSE/SLE 
versions.
-# Up to openSUSE 13.2 and SLE11 CUPS < 1.6 is provided (from CUPS 1.3.9 for 
SLE11 up to CUPS 1.5.4 for openSUSE 13.2).
-# For SLE12 by default CUPS 1.7.5 is provided and alternatively CUPS 1.5.4 is 
provided in the "legacy" module.
-# After openSUSE 13.2 (i.e. for current openSUSE Factory) CUPS 2.0 is provided.
-# Up to openSUSE 13.2 and SLE12 it BuildRequires CUPS < 1.6 to ensure it even 
works on SLE12 with CUPS 1.5.4.
-# When it was built with CUPS > 1.5 it must also require CUPS > 1.5 during 
run-time.
-# In contrast when it was built with CUPS < 1.6 there must not be a run-time 
requirement
-# for a CUPS version to ensure it works on SLE12 both with CUPS 1.7.5 and CUPS 
1.5.4.
-# For suse_version values see 
https://en.opensuse.org/openSUSE:Build_Service_cross_distribution_howto
-%if 0%{?suse_version} > 1320 || %{is_leap}
-# For openSUSE after 13.2 (i.e. for current openSUSE Factory) CUPS > 1.5 is 
provided and required:
-BuildRequires:  cups > 1.5
-BuildRequires:  cups-devel > 1.5
-Requires:       cups > 1.5
-%endif
-%if 0%{?suse_version} == 1315 && !%{is_leap}
-# For SLE12 build it with traditional CUPS 1.5.4 to ensure it works on SLE12 
both with CUPS 1.7.5 and CUPS 1.5.4.
-# Only in the Printing project for SLE12 use cups154 and cups154-devel (from 
the cups154-SLE12 source package):
-BuildRequires:  cups154
-BuildRequires:  cups154-devel
-Requires:       cups
-%endif
-%if 0%{?suse_version} == 1320 || 0%{?suse_version} < 1315
-# For openSUSE 13.2 and for openSUSE 13.1 and older openSUSE and SLE11 
versions CUPS < 1.6 is provided:
-BuildRequires:  cups < 1.6
-BuildRequires:  cups-devel < 1.6
-Requires:       cups
-%endif
 BuildRequires:  dbus-1-devel
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme
@@ -118,22 +91,6 @@
 BuildRequires:  python-qt4
 BuildRequires:  python-xml
 BuildRequires:  readline-devel
-%if 0%{?suse_version} > 1130
-BuildRequires:  sane-backends-devel
-%else
-BuildRequires:  sane-backends
-%endif
-# For udev macros
-%if 0%{?suse_version} > 1130
-BuildRequires:  systemd-rpm-macros
-%else
-# For older suse_version (in particular for SLE11) define needed udev macros 
manually:
-%{!?_udevrulesdir: %global _udevrulesdir /usr/lib/udev/rules.d }
-%endif
-%if 0%{?suse_version} == 1110
-# For SLE11 redefine _libexecdir because on SLE11 _libexecdir is "/usr/lib64":
-%global _libexecdir /usr/lib
-%endif
 BuildRequires:  update-desktop-files
 # Require the exact matching version-release of the hpijs sub-package to make 
sure
 # to have the exact matching version of libhpip and libhpmud installed.
@@ -193,6 +150,48 @@
 Obsoletes:      hplip3 < 3.9.5
 # Install into this non-root directory (required when norootforbuild is used):
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
+# HPLIP's Python module cupsext.so has a build-time dependancy on the CUPS 
version:
+# It needs symbols (like ippFirstAttribute, ippNextAttribute, ippSetOperation 
etc)
+# that are defined only in libcups.so version > 1.5. For backward compatibility
+# cupsext.c has a macro (CUPS_VERSION_1_6) which defines those undefined 
function names
+# if CUPS version is <= 1.5. To check the CUPS version the CUPS_VERSION_MAJOR, 
CUPS_VERSION_MINOR
+# macros from cups/cups.h are used which means it depends on the CUPS version 
during build-time
+# whether or not cupsext will work with CUPS <= 1.5 at run-time.
+# See https://bugs.launchpad.net/hplip/+bug/1423220
+# and https://bugzilla.opensuse.org/show_bug.cgi?id=918387
+# Therefore it BuildRequires the CUPS version as provided in the openSUSE/SLE 
versions.
+# Up to openSUSE 13.2 and SLE11 CUPS < 1.6 is provided (from CUPS 1.3.9 for 
SLE11 up to CUPS 1.5.4 for openSUSE 13.2).
+# For SLE12 by default CUPS 1.7.5 is provided and alternatively CUPS 1.5.4 is 
provided in the "legacy" module.
+# After openSUSE 13.2 (i.e. for current openSUSE Factory) CUPS 2.0 is provided.
+# Up to openSUSE 13.2 and SLE12 it BuildRequires CUPS < 1.6 to ensure it even 
works on SLE12 with CUPS 1.5.4.
+# When it was built with CUPS > 1.5 it must also require CUPS > 1.5 during 
run-time.
+# In contrast when it was built with CUPS < 1.6 there must not be a run-time 
requirement
+# for a CUPS version to ensure it works on SLE12 both with CUPS 1.7.5 and CUPS 
1.5.4.
+# For suse_version values see 
https://en.opensuse.org/openSUSE:Build_Service_cross_distribution_howto
+%if 0%{?suse_version} > 1320 || %{is_leap}
+# For openSUSE after 13.2 (i.e. for current openSUSE Factory) CUPS > 1.5 is 
provided and required:
+BuildRequires:  cups > 1.5
+BuildRequires:  cups-devel > 1.5
+Requires:       cups > 1.5
+%endif
+%if 0%{?suse_version} == 1315 && !%{is_leap}
+# For SLE12 build it with traditional CUPS 1.5.4 to ensure it works on SLE12 
both with CUPS 1.7.5 and CUPS 1.5.4.
+# Only in the Printing project for SLE12 use cups154 and cups154-devel (from 
the cups154-SLE12 source package):
+BuildRequires:  cups154
+BuildRequires:  cups154-devel
+Requires:       cups
+%endif
+%if 0%{?suse_version} == 1320 || 0%{?suse_version} < 1315
+# For openSUSE 13.2 and for openSUSE 13.1 and older openSUSE and SLE11 
versions CUPS < 1.6 is provided:
+BuildRequires:  cups < 1.6
+BuildRequires:  cups-devel < 1.6
+Requires:       cups
+%endif
+%if 0%{?suse_version} > 1130
+BuildRequires:  sane-backends-devel
+%else
+BuildRequires:  sane-backends
+%endif
 
 %description
 The Hewlett-Packard Linux Imaging and Printing project (HPLIP) provides
@@ -230,7 +229,6 @@
 
 %package hpijs
 Summary:        Only plain printing with HPLIP printer drivers
-Group:          Hardware/Printing
 # On a minimalist system only hplip-hpijs may be installed
 # or on a minimalist package repository (e.g. on the openSUSE CDs)
 # only hplip-hpijs may be available (even when a usual system is installed).
@@ -249,6 +247,7 @@
 # may be not available to be installed (e.g. when hplip-hpijs-1.2.3-4.5 is
 # installed from the openSUSE CDs but on our official online repository
 # only hplip-1.2.3-6.7 is available which should usually also work):
+Group:          Hardware/Printing
 Suggests:       %{name} = %{version}
 # Since Nov 14 2007 ghostscript-library does no longer require /usr/bin/hpijs
 # but only "Suggests hplip-hpijs" (see Novell/Suse Bugzilla bnc#341564).
@@ -310,12 +309,12 @@
 
 %package sane
 Summary:        Only plain scanning with HPLIP scan drivers
-Group:          Hardware/Scanner
 # Require the exact matching version-release of the hpijs sub-package to make 
sure
 # to have the exact matching version of libhpip and libhpmud installed.
 # A wrong library version may let libsane-hpaio crash (e.g. segfault)
 # which lets the whole scanning stack frontend<->libsane-dll<->libsane-backend 
crash
 # also for any other backend when the hpaio backend is enabled (e.g. 
"scanimage -L"):
+Group:          Hardware/Scanner
 Requires:       %{name}-hpijs = %{version}-%{release}
 # See comment in hpijs sub-package for same Suggests:
 Suggests:       %{name} = %{version}
@@ -330,9 +329,9 @@
 
 %package devel
 Summary:        Development files for hplip
-Group:          Development/Languages/C and C++
 # Require the exact matching version-release of the hpijs sub-package to make 
sure
 # to have the exact matching version of libhpip and libhpmud installed:
+Group:          Development/Languages/C and C++
 Requires:       %{name}-hpijs = %{version}-%{release}
 # Require the exact matching version-release of the sane sub-package to make 
sure
 # to have the exact matching version of libsane-hpaio installed:
@@ -644,9 +643,9 @@
 %files
 %defattr(-, root, root)
 %config %{_sysconfdir}/xdg/autostart/hplip-systray.desktop
-%if 0%{?suse_version} == 1110 || 0%{?suse_version} == 1320 || %{is_leap}
-%dir /usr/lib/udev
-%dir /usr/lib/udev/rules.d
+%if 0%{?suse_version} == 1110 || 0%{?suse_version} == 1320 || 
0%{?suse_version} == 1315
+%dir %{_prefix}/lib/udev
+%dir %{_prefix}/lib/udev/rules.d
 %endif
 %config %{_udevrulesdir}/56-hpmud.rules
 %{_bindir}/hp-align
@@ -710,7 +709,7 @@
 %config %{_sysconfdir}/cups/pstotiff.convs
 %config %{_sysconfdir}/cups/pstotiff.types
 %{_bindir}/hpijs
-%doc %{_mandir}/man1/hpijs.1.gz
+%{_mandir}/man1/hpijs.1.gz
 %{_libdir}/libhpip.so.*
 %{_libdir}/libhpipp.so.*
 %{_libdir}/libhpmud.so.*


++++++ hplip-3.16.8.tar.gz -> hplip-3.16.10.tar.gz ++++++
/work/SRC/openSUSE:Factory/hplip/hplip-3.16.8.tar.gz 
/work/SRC/openSUSE:Factory/.hplip.new/hplip-3.16.10.tar.gz differ: char 5, line 
1



Reply via email to