Hello community,

here is the log from the commit of package yast2 for openSUSE:Factory checked 
in at 2018-02-02 22:18:55
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/yast2 (Old)
 and      /work/SRC/openSUSE:Factory/.yast2.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "yast2"

Fri Feb  2 22:18:55 2018 rev:416 rq:572018 version:4.0.49

Changes:
--------
--- /work/SRC/openSUSE:Factory/yast2/yast2.changes      2018-01-28 
00:38:23.816393325 +0100
+++ /work/SRC/openSUSE:Factory/.yast2.new/yast2.changes 2018-02-02 
22:18:55.847263234 +0100
@@ -1,0 +2,69 @@
+Fri Feb  2 11:25:21 UTC 2018 - igonzalezs...@suse.com
+
+- Y2Packager::Product does not depend on Yast::Language module
+  anymore (related to bsc#1079045)
+- 4.0.49
+
+-------------------------------------------------------------------
+Thu Feb  1 11:36:31 UTC 2018 - igonzalezs...@suse.com
+
+- Replace idnconv with simpleidn library (related to bsc#1071552).
+- Move some Y2Packager classes from yast2-packager here to
+  fix the package build.
+- 4.0.48
+
+-------------------------------------------------------------------
+Thu Feb  1 10:36:26 UTC 2018 - knut.anders...@suse.com
+
+- Firewalld: Cache modifications for performance improvements.
+  (fate#323460)
+- 4.0.47
+
+-------------------------------------------------------------------
+Thu Feb  1 08:09:28 UTC 2018 - lsle...@suse.cz
+
+- Move some Y2Packager classes from yast2-packager here to avoid
+  circular dependency (related to fate#323163)
+- 4.0.46
+
+-------------------------------------------------------------------
+Wed Jan 31 13:54:12 UTC 2018 - knut.anders...@suse.com
+
+- Firewalld API: Cache whether the configuration has been read
+  (fate#323460)
+- 4.0.45
+
+-------------------------------------------------------------------
+Tue Jan 30 11:06:59 UTC 2018 - knut.anders...@suse.com
+
+- Installation::AutoClient: modified packages default and improved
+  documentation (fate#323460 bsc#1077987)
+- 4.0.44
+
+-------------------------------------------------------------------
+Tue Jan 30 06:45:17 UTC 2018 - an...@suse.com
+
+- Fixed a bug causing pages of all CWM::TreePager to be rendered
+  twice on every page switch (bsc#1078212)
+- 4.0.43
+
+-------------------------------------------------------------------
+Mon Jan 29 17:11:19 UTC 2018 - knut.anders...@suse.com
+
+- Firewalld API: reload and complete reload return true in offline
+  mode (fate#323460)
+- 4.0.42
+
+-------------------------------------------------------------------
+Mon Jan 29 14:11:59 UTC 2018 - knut.anders...@suse.com
+
+- Fixed logging typo (fate#1076513)
+- 4.0.41
+
+-------------------------------------------------------------------
+Fri Jan 26 14:25:07 UTC 2018 - lsle...@suse.cz
+
+- Improved base product detection at upgrade (fate#1076513)
+- 4.0.40
+
+-------------------------------------------------------------------

Old:
----
  yast2-4.0.39.tar.bz2

New:
----
  yast2-4.0.49.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ yast2.spec ++++++
--- /var/tmp/diff_new_pack.MyDbuD/_old  2018-02-02 22:18:56.483233544 +0100
+++ /var/tmp/diff_new_pack.MyDbuD/_new  2018-02-02 22:18:56.483233544 +0100
@@ -17,7 +17,7 @@
 
 
 Name:           yast2
-Version:        4.0.39
+Version:        4.0.49
 Release:        0
 Summary:        YaST2 - Main Package
 License:        GPL-2.0
@@ -39,6 +39,8 @@
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:cheetah)
 # For running RSpec tests during build
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:rspec)
+# For converting to/from punycode strings
+BuildRequires:  rubygem(%{rb_default_ruby_abi}:simpleidn)
 # Needed already in build time
 BuildRequires:  yast2-core >= 2.18.12
 BuildRequires:  yast2-devtools >= 3.1.10
@@ -65,8 +67,10 @@
 # for defining abstract methods in libraries
 Requires:       rubygem(%{rb_default_ruby_abi}:abstract_method)
 # for file access using augeas
-Requires:       sysconfig >= 0.80.0
 Requires:       rubygem(%{rb_default_ruby_abi}:cfa)
+# For converting to/from punycode strings
+Requires:       sysconfig >= 0.80.0
+Requires:       rubygem(%{rb_default_ruby_abi}:simpleidn)
 # for running scripts
 Requires:       rubygem(%{rb_default_ruby_abi}:cheetah)
 # ag_ini section_private
@@ -94,15 +98,8 @@
 # moved cfg_mail.scr
 Conflicts:      yast2-mail < 3.1.7
 # Older packager use removed API
-Conflicts:      yast2-packager < 3.1.34
+Conflicts:      yast2-packager < 4.0.33
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-# for Punycode.rb (bnc#651893) - the idnconv tool is located in
-# different packages (SLE12/Leap-42.1: bind-utils, TW/Factory: idnkit)
-%if 0%{?suse_version} >= 1330
-Requires:       idnkit
-%else
-Requires:       bind-utils
-%endif
 Obsoletes:      yast2-devel-doc
 # for the PackageExtractor class, just make sure they are present,
 # these should be present even in a very minimal installation

++++++ yast2-4.0.39.tar.bz2 -> yast2-4.0.49.tar.bz2 ++++++
++++ 4690 lines of diff (skipped)


Reply via email to