Hello community,

here is the log from the commit of package claws-mail for openSUSE:Factory 
checked in at 2018-07-14 20:25:24
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/claws-mail (Old)
 and      /work/SRC/openSUSE:Factory/.claws-mail.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "claws-mail"

Sat Jul 14 20:25:24 2018 rev:81 rq:622477 version:3.16.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/claws-mail/claws-mail.changes    2018-05-29 
10:28:26.149011804 +0200
+++ /work/SRC/openSUSE:Factory/.claws-mail.new/claws-mail.changes       
2018-07-14 20:27:34.248548236 +0200
@@ -1,0 +2,8 @@
+Sun Jul  8 17:32:22 UTC 2018 - bjorn....@gmail.com
+
+- Replace enchant-devel with pkgconfig(enchant), current version
+  does not support enchant-2. Fixed upstream for next version.
+- Replace NetworkManager-devel with pkgconfig(libnm), align with
+  what configure looks for.
+
+-------------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ claws-mail.spec ++++++
--- /var/tmp/diff_new_pack.8qfAxY/_old  2018-07-14 20:27:34.744549510 +0200
+++ /var/tmp/diff_new_pack.8qfAxY/_new  2018-07-14 20:27:34.748549520 +0200
@@ -38,11 +38,9 @@
 Source:         
http://www.claws-mail.org/download.php?file=releases/%{name}-%{version}.tar.xz
 Patch:          libcanberra-gtk3.patch
 Patch2:         Do-not-use-msginfo_list-for-compose.patch
-BuildRequires:  NetworkManager-devel
 BuildRequires:  compface-devel
 BuildRequires:  db-devel
 BuildRequires:  docbook-utils
-BuildRequires:  enchant-devel
 BuildRequires:  fdupes
 BuildRequires:  gettext
 BuildRequires:  gmp-devel
@@ -77,7 +75,10 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(dbus-1) >= 0.60
 BuildRequires:  pkgconfig(dbus-glib-1) >= 0.60
+## FIXME ## - On next version bump please replace with pkgconfig(enchant-2)
+BuildRequires:  pkgconfig(enchant)
 BuildRequires:  pkgconfig(gnutls) >= 2.2
+BuildRequires:  pkgconfig(libnm)
 BuildRequires:  pkgconfig(libnotify)
 BuildRequires:  pkgconfig(libsoup-2.4)
 BuildRequires:  pkgconfig(sm)


Reply via email to